Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Advocate I
Advocate I

Power BI online refresh - 'Microsoft.ACE.OLEDB.12.0' error



I'm getting this error when trying to refresh Power BI dataset online (scheduled and manual refresh):


Excel Workbook: The 'Microsoft.ACE.OLEDB.12.0' provider is not registered on the local machine. The 64-bit version of the Access Database Engine 2010 Access Database Engine OLEDB provider may be required to read this type of file. To download the client software, visit the following site:


In Power BI Desktop everything is working fine. The source data is located at sharepoint online and it's .xlsb file with few tabs (4 tables taken from 4 tabs in this file). 

Does anyone know how to solve this?




New Member

Sharing this as it may be useful to someone, I had the same error but resolved now.

Using PowerBI Desktop (2.122.1066.0 64-bit (October 2023)

XLSX file on a SharePoint Site


This was working previously, bottom line for me was the addtion of files in to the same SharePoint libray.


Am new to PowerBI and there would be a better way to conenct to the SharePoint hosted .xlsx file in the first place, but that was the casue.


My original connection to the .xlsx in SharePoint:

Get Data > More > SharePoint folder > Connect > URL to the site > OK

This bought a list of all the files in the site (in a large site it won't be very friendly to scroll this list), then:

Transform Data > this opens up Power Query Editor with a list of the content of the site and the APPLIED STEPS pane > used the Remove Rows Top and Remove Rows Bottom so that a single row of my .xlsx remained.


Resolved it by editing the data query (in PowerBI, DATA > Click the three dots next to the query > Edit query), this opened up the Power Query Editor and the bar below the column header row was Red/White stripes.


Worked up from bottom of the APPLIED STEPS until the bar turned green and noticed that although it was at 'Removed Bottom Rows' step there were still row below the .xlsx row. Removed the step and reinserted the 'Remove Bottom Row' with the correct number of rows removed so that the .xlsx with my data was the only row remaining.


I was then able to apply and save, and refresh the report.


It's a test enviornment so not a major issue, and can investiage how to query a file in a library without having to worry about anything being added/removed from the library.






Custom query to pick out the specific .xlsx file from the site. Successfully tested by adding and removing files to the site and the reports continued to work.

Regular Visitor

I have same issue, was there a resolution mentioned that I missed?  Thanks for any help! 

Please update the file type to .xlsx (Excel Workbook) and it will be good

If this post helps, then please consider Accept it as the solution, Appreciate your Kudos!!
Proud to be a Super User!!
New Member

Does anyone know how to solve this online Error?

You can follow any one of below
1. Convert your file from .xlsb to .xlsx

2. Configure a gateway and install The 64-bit version of the Access Database Engine 2010 Access Database Engine OLEDB provider on gateway server
then create a data source for this .xlsb file (even it is on SharePoint)

If this post helps, then please consider Accept it as the solution, Appreciate your Kudos!!
Proud to be a Super User!!
Advocate I
Advocate I

Same issue.  Works fine on Desktop, but on the service the error comes up.

To reiterate...

The Query looks into a SP online folder.  It is supposed to grab all the .xls files and combine them.  Works fine on Desktop, but published to the service the error occurs.

If I open each excel and save it as xlsx, then it is okay.  But there are to many files to convert. These files are sent daily and dropped into the folder automatically using Power Automate.


Not applicable

I have the same issue with xlsx files stored on sharepoint online. I fix has been found ?

Kudo Commander
Kudo Commander

In schedule refresh, Power BI only likes Excel files in xlsx extension when saved in the cloud, I had to resave all files to this extension and worked.


Annotation 2019-10-31 123359.png


Hi @Oscar_Mtz_V 


I want to know how you solved your problem , my report is on sharepoint hw can I change he type or extenseion 


Thanks a lot

@OHOODSA  you need to update the file extension on SharePoint itself

If this post helps, then please consider Accept it as the solution, Appreciate your Kudos!!
Proud to be a Super User!!

Thank you @arvindsingh802 for your reply


How can I change the Extention in sharepoint 

You can download the file, update the extension and upload to sharepoint again

If this post helps, then please consider Accept it as the solution, Appreciate your Kudos!!
Proud to be a Super User!!

that worked for me, thanks! 
I used the VBA-Code on to bulk resave the files. I had some files with the ending .xls and some with .XLS (Upper Case). For the latter I had to change the code by replacing xls with XLS.

Not applicable

Same here,


would like to check if theres a solution to this in PBI service, on desktop it  works fine

Not applicable



I'd like to check if there is any recommended solution to this issue, other than changing the file format of the data source.


I am facing the same problem with refreshing my dataset through Power BI Service, while the required Microsoft.ACE.OLEDB.12.0 provider is already installed on my machine (the same version as Power BI Desktop and all Office apps), and everything works fine in Power BI Desktop.


Thank you!



Community Support
Community Support

Hi @joannab ,


The download for MS Access Database Engine Redistributable can be found here. Be sure to check the same version as your Power BI Desktop is installed! For more details, please refer  to the third - party blog.


Community Support Team _ Frank
If this post helps, then please consider Accept it as the solution to help the others find it more quickly.
Not applicable


I'm still awaiting confirmation as to whether or not this is an issue. I am still unable to refresh my reports and will be looking for alternatives if this is not resolved. 

Thank you, but it doesn't solve the issue.


Refresh in Power BI Desktop works correctly. The issue exists when I want to refresh dataset online using scheduled refresh and manual as well.

Not applicable


I am having the same issue. 


@v-frfei-msft ,

Has this been resolved?



it hasn't been resolved on my side. I noticed the cause in this particular case is the source file format - I use .xlsb file. When I save it as .xlsm or .xlsx it's working good, but it's not the satisfying solution for me. 


I also have the same issue in another project when using .xls or .accdb source files. Everything is refreshing with no issues on desktop (Access Database Engine installed) but refresh online returns this error.


Please let me know if you find any news on that.

Helpful resources

July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

July Newsletter

Fabric Community Update - July 2024

Find out what's new and trending in the Fabric Community.