Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
DSQU
Frequent Visitor

Power BI Sign in Issue Report Server Migrating RDL to Power BI Service

Hello 

 

I am having an issue where I go to my on-prem Power BI Report Server, go to publish, select a report to publish, and pick a report to publish out to the Power BI Service, hit the green publish to Power bi button in the bottom right corner.  

 

It then shows the green Sign In button for the Power BI service. I click it, a tab opens and it instantly closes. 

 

Random notes: 

  • I was able to publish reports without issue just last week. I could choose a workspace and send the report over. 
  • The power bi report server was installed last week so we have a recent version.
  • If i clear cookies/try incognito, it lets me click the sign in button, login to microsoft but it instantly closes the tab again after I am done logging in. 
  • Tried multiple browswers
  • Tried disabling pop ups blockers and adjusting all browser config options that might limit tabs you can open 
  • Tried different reports, the same reports that worked last week, etc. 
  • The issue seems behaves exactly the same as the video in this thread: https://community.fabric.microsoft.com/t5/Issues/PowerBI-Sign-In-Issue-in-Chrome/idi-p/3519325
  • Tried rebooting the server that hosts the power bi report server 
  • Tried logging into that server directly and publishing from there, and get the same issue. 
  • Tried other people on my team doing the same deployment
  • After working with support, the only thing we think changed on the server in the last few days is we uninstalled an old Microsoft Access Engine 2010 DLL on the server. Unsure how it could be related but figured I would mention it. 
  • I can deploy reports from Power BI desktop and Power BI report builder tools without issue. 

 

1 ACCEPTED SOLUTION
DSQU
Frequent Visitor

Seems to be a edge/chrome issue, or power bi service issue, after i found this thread saying firefox worked, which worked for me too: https://www.reddit.com/r/PowerBI/comments/1bjhmfr/ssrs_publish_to_power_bi_not_working_in_chromeedge...

View solution in original post

8 REPLIES 8
againey11
New Member

Is this a known issue with the January 2024 update to PBIRS? We just installed that update to our system and are now seeing the same behavior from the "migrate" function in the User Interface. I have made sure that the app.powerbigov.us url is an allowed url and no pop up blockers are affecting it... as mentioned the FIRST time on a fresh browser (edge or chrome) that I click the "sign in" to power bi button it behaves like its going to work and opens a sign in window. when I enter my credentials it spins and then the window disappears. Anytime trying to hit the green "sign in" button after that you can tell the browser very quickly tries to open the link in a new tab but it just immediately closes and dissapears. This is starting to seem like a bug or severe lack of compatibility with modern browsers. We did not have this issue with prior updates for PBIRS until the Jan 2024. Any ideas on how to resolve this? We are planning a massive migration from on-premise to PBI Service and this feature is critical (35,000 report files) 

DSQU
Frequent Visitor

Seems to be a edge/chrome issue, or power bi service issue, after i found this thread saying firefox worked, which worked for me too: https://www.reddit.com/r/PowerBI/comments/1bjhmfr/ssrs_publish_to_power_bi_not_working_in_chromeedge...

v-kaiyue-msft
Community Support
Community Support

Hi @DSQU ,

Please press f12 on the power bi service page, then click the login button, check the error message in the window, and troubleshoot the error. You can share the error information to better help you solve the problem.

 

If your Current Period does not refer to this, please clarify in a follow-up reply.

 

Best Regards,

Clara Gong

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Thank you. This is the error that is coming up. 401 unauthorized on this file: 

https://XXXXXXXXX.net/ReportsPBI/assets/img/fi/pbirs/manifest.json

 

I can't find the file just browsing around the power bi report server installation 

 

DSQU_0-1711032050020.png

 

DSQU
Frequent Visitor

I uninstalled report services altogether, and re-installed, and i'm getting the same error as above: 

DSQU_0-1711042877848.png

 

DSQU
Frequent Visitor

adding that we were able to grab the link that pops up and instantly closes out, then nothing happens: 

https://app.powerbi.com/autoAuthLogin?noSignUpCheck=1&clientSideAuth=0

GilbertQ
Super User
Super User

Hi @DSQU 

 

I would recommend re-installing the Microsoft Access Engine 2010 DLL on the server just to ensure that there is nothing missing.





Did I answer your question? Mark my post as a solution!

Proud to be a Super User!







Power BI Blog

DSQU
Frequent Visitor

Yes thank you I forgot to mention, we tried re-installing the driver and testing again, with no luck. 

Helpful resources

Announcements
Europe Fabric Conference

Europe’s largest Microsoft Fabric Community Conference

Join the community in Stockholm for expert Microsoft Fabric learning including a very exciting keynote from Arun Ulag, Corporate Vice President, Azure Data.

Power BI Carousel June 2024

Power BI Monthly Update - June 2024

Check out the June 2024 Power BI update to learn about new features.

PBI_Carousel_NL_June

Fabric Community Update - June 2024

Get the latest Fabric updates from Build 2024, key Skills Challenge voucher deadlines, top blogs, forum posts, and product ideas.

Top Solution Authors