Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
Anonymous
Not applicable

Power BI Service Dates

 Hi Power BI,

 

My Power BI desktop has been correctly configured to my locale (Australia).

However any reports that i publish into Power BI Service have US style dates, and the timings have been coverted to US.

 

e.g. I check my usage stats on the reports i built. I know that i only look at my reports during business hours, but the usage statistics says i logged in on Sunday to view. This is not correct but i am assuming because it is in "US-time".

 

Does anyone know how i can fix the US times on Power BI service?? (i.e. the web interface)?

 

Thanks

Oneiricer

5 REPLIES 5
GilbertQ
Super User
Super User

Hi there

If your PBIX file is using the DAX functions of NOW() or TODAY() as well as any of the Power Query Functions these will be default always log it as UTC.

What I suggest to people is if the dates are set to UTC (Which are the timezone for all Power BI Servers) I suggests adding the required HOURS to the dataset.

Here is my blog post explaining how all the servers are, as well as a means to change the Time: https://www.fourmoo.com/2017/10/03/power-bi-did-you-know-all-power-bi-services-servers-are-in-utc-no...




Did I answer your question? Mark my post as a solution!

Proud to be a Super User!







Power BI Blog

Anonymous
Not applicable

Thanks. I do use today() functions in DAX so this explains part of the problem.

 

The other problem is that i have slicers that allow the user to control the date range. These are also changed to US styled dates. This is not something i can use DAX to change as these use the slicer functionality out of the box.


Do you know of a solution to this?

Many thanks

Oneiricer

 

Power BI.PNG

Hi @Anonymous

 

That is really interesting when I look at my dates in the Power BI Service, I have them as shown below.

 

image.png

 

I do have a Date table setup.

I also ensured that I have got my Locale Settings, setup via Internet Explorer (Yes I know!) are set with the default being Australia.


If that does not work let me know.





Did I answer your question? Mark my post as a solution!

Proud to be a Super User!







Power BI Blog

Anonymous
Not applicable

Hi @GilbertQ,


My locale settings for IE are set in Australia as well.

I only experience this isue using Power BI service. The dates display correctly in Power BI desktop.

 

I feel like it is some setting that needs to be done for Office 365 and/or Power BI, but i am not the administrator for my company.

 

Any other ideas?

 

Thanks

Oneiricer

Hi there

I have actually found that for me it had to be done in the PBIX from what I recall.

As far as I can see there are no settings in the Power BI Admin Centre.

Are you running Windows 10, if so also check your Date & Time settings?




Did I answer your question? Mark my post as a solution!

Proud to be a Super User!







Power BI Blog

Helpful resources

Announcements
July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

July Newsletter

Fabric Community Update - July 2024

Find out what's new and trending in the Fabric Community.