Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
shaunb94
Helper I
Helper I

Power BI Report not refreshing in Power BI Service but refreshing in Desktop

Hi, 

 

I am having an extremely frustrating time trying to configure a refresh on a Power BI report on Power BI Service. 

 

The data source is mySQL and when I do a refresh using the credentials and using the IP that is whitelisted, the refresh suceeeds perfectly in Power BI Desktop everytime. 

 

However, when I try & refresh in Service & reenter the credentials I am getting the error message in the first snip below: 

 

I don't think it relates to a gateway as Power BI seems to be reading the mySQL data source as a cloud connection based off my 2nd image? 

 

Does anyone have any ideas as to why this is only failing in Power BI Service?

shaunb94_0-1716369695865.png

 

 

 

 

I would really appreciate some help! 🤞

9 REPLIES 9
collinq
Super User
Super User

Hi @shaunb94 ,

 

I would go ahead and create a Gateway and a Data Source and use a Service Account that is read only to access the data.  I did find this article which is slightly different but makes the statement that you need a gateway: "A data gateway is required to use MySQL with Power BI query online". from Connect with Power BI - Azure Database for MySQL - Flexible Server | Microsoft Learn

 




Did I answer your question? Mark my post as a solution!

Proud to be a Datanaut!
Private message me for consulting or training needs.




Thanks for the reply @collinq

 

When you say use a service account is read only, do you not think I can just use my current power bi account once I have gateway configured if the gateway is the issue? 

or are you referring to an account on the actual Database? 

Hey @shaunb94 ,

 

I am referring to the database.  This ensures that you have an account that has the right permissions and that you can re-use the Data Source/Gateway setup again for other folks as well.




Did I answer your question? Mark my post as a solution!

Proud to be a Datanaut!
Private message me for consulting or training needs.




Also, I am going ahead & following the steps in the link to the forum you posted @collinq, but still seem to be getting this error message? 

shaunb94_2-1716369468686.png

 

 

Would something perhaps need to be done on the Database/Server?

 

Again, I have no issues when I try to connect via Power BI Desktop.



Hey @shaunb94 ,

 

I understand that you do not have problems with your userid inside your network but since this is the service I am suggesting that you setup a gateway and data source to confirm that the data credentials is (or is not) the true issue.  I also understand that the data may be "cloud" but this happens sometimes based on all sorts of settings that you have to use a gateway even though the data source is "cloud".




Did I answer your question? Mark my post as a solution!

Proud to be a Datanaut!
Private message me for consulting or training needs.




Thanks @collinq, I have set up the gateway and data source in the above snip and it is still giving that error though?

Hey @shaunb94 ,

 

You need to confirm that the encryption level and privacy level in the Service matches what you have in the Desktop file as well.  (I would guess that the privacy level is probably "Organizational" and not "Public") And then, after trying again with those being the same let us know if you get another error message.




Did I answer your question? Mark my post as a solution!

Proud to be a Datanaut!
Private message me for consulting or training needs.




I know it is not encrypted as it gives me this message when I connect it to Power BI Desktop. 

In terms of privacy level, I have tried each one of them multiple times unfortunately! 😅 

Could it relate to the IP of where Power BI is storing & trying to refresh this report from by any chance? I am refreshing off a VM which is whitelisted so I doubt it? 

Anything else it could be?

Hey @shaunb94 ,

 

I am also assuming that you ahve tried with "Basic", "Windows", Oauth connection types?  Just to make sure they are all correct.

 

If the error is really the first part of the message - that the gateway can't access the data source - then I would check with your network/firewall folks and confirm that the gateway is in fact talking to the database.

 

ANother thing that you can do is run a network trace (like using fiddler) and look at the log to see where the issue might be in the process.  The goal would be to get a "better" error message so you know where the current hurdle resides.

 

Also, have you confirmed that the gateway is updated to the latest version?




Did I answer your question? Mark my post as a solution!

Proud to be a Datanaut!
Private message me for consulting or training needs.




Helpful resources

Announcements
Europe Fabric Conference

Europe’s largest Microsoft Fabric Community Conference

Join the community in Stockholm for expert Microsoft Fabric learning including a very exciting keynote from Arun Ulag, Corporate Vice President, Azure Data.

Power BI Carousel June 2024

Power BI Monthly Update - June 2024

Check out the June 2024 Power BI update to learn about new features.

PBI_Carousel_NL_June

Fabric Community Update - June 2024

Get the latest Fabric updates from Build 2024, key Skills Challenge voucher deadlines, top blogs, forum posts, and product ideas.

Top Solution Authors