Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
Anonymous
Not applicable

Power BI Export to Powerpoint "Embed an Image" function not retaining applied filters

In the Power BI Service, filters applied in the report are no longer being retained when the user selects Export | PowerPoint | Embed An Image | Export Current Values.  The filters are completely wiped out and a default view of the report (with no filters applied) is exported.  Is this a new bug?

 

2 ACCEPTED SOLUTIONS
Anonymous
Not applicable

Hi, Lance,

 

I spent about 3 hours with Microsoft Support on the phone yesterday and I believe we traced it back to the "Persisent Filters" setting on the report in the Power BI Service.  I prefer to leave this setting "on" so the report returns to its default setting (i.e., no prior filters from the last session are retained) when the user logs in again.   However, we found that we needed to turn this setting "off" in order for filters applied during the current session to be retained upon exporting.  It's not ideal, but at least a workaround exists in the meantime!

 

Here's a link to instructions on how to access and update the Persistent Filters setting in the Power BI Service - https://docs.microsoft.com/en-us/power-bi/create-reports/power-bi-report-settings?tabs=powerbi-servi...

 

I hope this helps!  I'll try and remember to report back when I get any updates from Microsoft Support on my ticket.

View solution in original post

Anonymous
Not applicable

Hi, all,

 

I'm pleased to report that the "Persistent Filters" bug appears to have been fixed.  I turned on the "Persistent Filters" report setting again, updated my Power BI Service apps, and have found that the applied filters are now retained when exporting to PowerPoint or PDF.  I've notified Microsoft Support of my testing results, but if you want to give it a try on your end, too, it would be great to have multiple testers!

 

Thanks,

 

Krista

View solution in original post

10 REPLIES 10
lmillot
Frequent Visitor

Hi @Anonymous,

 

We're facing the same issue. I've submitted a ticket as well.

 

Any updates/solution provided from your ticket?

 

Lance

Anonymous
Not applicable

Hi, Lance,

 

I spent about 3 hours with Microsoft Support on the phone yesterday and I believe we traced it back to the "Persisent Filters" setting on the report in the Power BI Service.  I prefer to leave this setting "on" so the report returns to its default setting (i.e., no prior filters from the last session are retained) when the user logs in again.   However, we found that we needed to turn this setting "off" in order for filters applied during the current session to be retained upon exporting.  It's not ideal, but at least a workaround exists in the meantime!

 

Here's a link to instructions on how to access and update the Persistent Filters setting in the Power BI Service - https://docs.microsoft.com/en-us/power-bi/create-reports/power-bi-report-settings?tabs=powerbi-servi...

 

I hope this helps!  I'll try and remember to report back when I get any updates from Microsoft Support on my ticket.

Thanks for this - Workaround worked for me although, like you, I prefer to have persistent filters on 😞 Will keep an eye on this thread to see if you post any updates

Thank you! This workaround seems to work for us as well.

Anonymous
Not applicable

Hi, everyone!

 

I checked in with Microsoft Support for a status update.  They have confirmed there is a bug with exporting tied to the persistent filter toggle in the Power BI Service report settings.  The ETA for a fix is 2/9/2023.  I'm glad there is a workaround or my clients would have declared mutiny long before February rolls around!

 

I'll let you know if I hear anything else from Microsoft Support.

 

Thanks,

 

Krista

Anonymous
Not applicable

Hi, all,

 

I'm pleased to report that the "Persistent Filters" bug appears to have been fixed.  I turned on the "Persistent Filters" report setting again, updated my Power BI Service apps, and have found that the applied filters are now retained when exporting to PowerPoint or PDF.  I've notified Microsoft Support of my testing results, but if you want to give it a try on your end, too, it would be great to have multiple testers!

 

Thanks,

 

Krista

Hi Krista,

 

Confirmed - All good with persistent filters over here 🙂 Thanks for the update

 

Rob

Anonymous
Not applicable

Great to hear!  Back to "business as usual." 🙂

GilbertQ
Super User
Super User

Hi @Anonymous 

 

This is the first I have heard of this. It was working in the past.

 

Could I ask you to try log out and back in and see if that works?

 

If not it might be a bug and you would need to log a support ticket: https://powerbi.microsoft.com/en-us/support/pro/





Did I answer your question? Mark my post as a solution!

Proud to be a Super User!







Power BI Blog

Anonymous
Not applicable

Hi, GilbertQ,

 

Thank you for getting back to me so quickly!

I've logged out and back in again several times, including clearing out my internet browser cache and trying again.  I've also tried exporting the report after being logged in for 2+ hours to see if it was possibly a syncing issue of some sort.  I've also had other licensed users try logging in and they are all experiencing the same issue.

I will follow your advice and log a support ticket.

 

Thanks,

 

Krista

Helpful resources

Announcements
July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

July Newsletter

Fabric Community Update - July 2024

Find out what's new and trending in the Fabric Community.