Forum Discussion
Power BI Copilot option on report embed link
Hi,
I am using power bi copilot which is available with reportembed link using "enable copilot option".
from last 2 days, copilot is unresponsive on reportembed link, for any user question it says "working on it" and keeps loading forever. It was working fine before. please help me understand if these is any issue going on with using copilot on reportemebed link ? This is very important for us as we use reportembed link only.
Copilt is responding in service mode, but our end users use embed links so this issue will block thise feature for us.
Please help.
6 Replies
- AbhaFrequent Visitor
thanks v-saisrao-msft Ahmed-Elfeel , this is with suppport team now.
- v-saisrao-msft
Community Support
Hi Abha,
Thank you for the update.
- Ahmed-Elfeel
Super User
Hi Abha,
Approach 1: Basic Checks
- Clear Browser Cache & Test in Incognito Mode
- Check for Console Errors:
- Open the browser Developer Tools (F12) -> Console tab.
- Reproduce the issue by asking Copilot a question.
- Look for any red JavaScript errors (These can point to authentication failures or script loading issues)
- Verify the Embed Feature is Still Enabled:
- In your embed code/config, double-check that the Copilot pane is explicitly set to visible: true
Approach 2: Investigate Microsoft Service Health (This determines if the problem is on Microsoft side)
- Go to the Microsoft 365 Admin Center (requires admin privileges)
- Navigate to Health > Service Health
- Check for Active Incidents related to (Power BI,Microsoft Copilot for Microsoft 365, Power BI Embedded)
Approach 3: Audit Your Power BI Tenant & License Config
- Go to Power BI Admin Portal -> Tenant settings.
Find Use Copilot in Power BI (Preview)
- Confirm it is enabled for your specific security group (or the entire org)
Note:
- Ensure every user experiencing the issue has a valid Power BI Premium Per User (PPU) license or that the workspace is hosted in a Premium Capacity (P/EM SKU) (Copilot will not work for Pro users in a nonPremium workspace)
Final Approach: Escalate to Microsoft Support
If any of solution i provided before didnt work you should do a formal escalation
- Gather Some Critical Information Like
- Workspace ID and Report ID of the failing report
- Correlation IDs (Reproduce the issue with the browsers Network tab (F12) open report)
- Timeline (The exact date and time when the problem started)
- User ID (The Azure AD Object ID of a affected user)
- Then Open a Support Ticket and Provide all gathered information
if this post helps, then I would appreciate a thumbs up and mark it as the solution to help the other members find it more quickly. - v-saisrao-msft
Community Support
Hi Abha,
Turn on Copilot in the embed settings and create a new embed link. Make sure the workspace is using Premium or Fabric (F2+) capacity, and that Copilot is activated in the tenant settings. Confirm that users are signed in with accounts that have Copilot licenses.
Thank you.
- AbhaFrequent Visitor
thanks v-saisrao-msft but its not working. workspace is copilot enabled with premium capcity. All required configuration are there to make copilot work and it was working well before. this week it has stopped working suddenly.
- v-saisrao-msft
Community Support
Hi Abha,
Please review the points shared by Ahmed-Elfeel, and check whether the issue is resolved. If the problem still persists, kindly raise a support ticket using the link below so that a backend engineer can assist in resolving it.
Create a Fabric and Power BI Support Ticket - Power BI | Microsoft Learn
Thank you.