cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Ilya-Tester
Regular Visitor

Paginated Reports never load 10+ columns

Hello.

 

I've created a new empty Power BI service account.

I need to it to learn Push Datasets API. I'm creating a dataset with tables and fill them up with my data.

 

My biggest table "forms" contains 44 rows and 22 columns.

 

And I'm completely unable to view the data in it using Power BI. I'm trying to create a new paginated report, but when I select more than ~10 columns then it just sticks forever loading. I tried to save the Report and open it to view but it's the same - it is just loading forever.

 

Any ideas how to fix this?

How are people supposed to use Power BI with real data if it's even unable to load a small 22x44 table?

 

IlyaTester_0-1680770001178.png

 

If I select just few columns then it works:

IlyaTester_1-1680770098039.png

 

8 REPLIES 8
rpatkar
Power BI Team
Power BI Team

Thank you for reporting! We identified this as a bug and fix will be released in coming weeks. For now, as you already figured out, workaround is to select one column at a time till you have selected all columns of interest. Somewhat related, when viewing wide tables, it's useful to use View / 'Web layout' so you can see all columns on screen, rather than the 'Print layout' that only shows 4 columns on the page.

Hello rpatkar,

 

That's good news. At least it wasn't a problem in our setup.

Regarding your advice with web layout - there is no difference, both layouts don't work when you select all columns in certain cases.

Hi Ilya-Tester,

 

We are not able to reproduce the issue. Can you open the dev tools and let us know what is going on in the network traffic and let the report keep running until it errors out? We can also use the X-Ms-Root-Activity-Id value from the 'render' request so we can look at backend traces.

No errors appear in the console when load fails. There is a standard bunch of messages on load:

IlyaTester_0-1684997584564.png

 

But when I select my "forms" table (only it is failing to load, other tables load fine) then it goes into infinite loop of "render" requests: https://recordit.co/moDmTRGF6A (demo video)

 

I tried to wait for a very long time, but it just shows "session expired - reload the page" at some moment.

 

X-Ms-Root-Activity-Id: fe0ab9b8-573b-93a3-00d2-99ea630f07a1

Hi Ilya-Tester,

 

Thanks for the RAID. From the backend trace, it looks like there is no data returned and no error for the rendering part of the request. We do look to have an existing bug we will fix if no data is returned, the spinner never goes away.

 

One other thing you can try is to do the same thing in a PBIX Power BI report to see what the behavior is there when you select the whole table.

Sorry, I'm not too familiar with Power BI to perform what you said 🙂

I imported my data using the Push Datasets REST API because it was my business task.

That is ok. If you do find the time, it is a couple of steps.

1. In the workspace that has your dataset, the ... ellipsis on the dataset will have the option to create a report. This is a PBIX report.

2. Create the report will open in a similar designer to the one you are using.

3. Perform the same thing, select the entire table.

4. Let us know what the behavior is.

 

Thanks again!

Hey @bradsy 

 

Thanks for detailed explanation. In this mode it works fine. Loads the selected columns immediately.

Helpful resources

Announcements
PBI Sept Update Carousel

Power BI September 2023 Update

Take a look at the September 2023 Power BI update to learn more.

Learn Live

Learn Live: Event Series

Join Microsoft Reactor and learn from developers.

Dashboard in a day with date

Exclusive opportunity for Women!

Join us for a free, hands-on Microsoft workshop led by women trainers for women where you will learn how to build a Dashboard in a Day!

MPPC 2023 PBI Carousel

Power Platform Conference-Power BI and Fabric Sessions

Join us Oct 1 - 6 in Las Vegas for the Microsoft Power Platform Conference.

Top Solution Authors
Top Kudoed Authors