Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
Amerikaner
Helper I
Helper I

Paginated Reporting / Power BI Premium Per User License

The documentation states supported data sources for Power BI Paginated Reports included Power BI Dataset (Premium and Non-Premium) and Premium Power BI Dataset XMLA. Upgrading from Power BI Pro to Premium Per User  (PPU), I tried to create the pagnated reports from the Report Builder. My problem is that there is no data connection option to either a local hard drive or the service to access the dataset. The 11 options begin with Microsoft SQL Server to Teradata. What do I need to do to connect the PowerBI datasets?

 

THX

1 ACCEPTED SOLUTION
AbhiSSRS
Solution Sage
Solution Sage

Hello @Amerikaner !

 

This works fine for me, I have worked with my power BI service hosted datsets connected live with a Premium per User workspace. It works the same way it works with Power Bi Desktop ,I only had to enable XMLA Read Write on my Power BI tenant .

AbhiSSRS_0-1618037414870.png

 

AbhiSSRS_1-1618037662724.png

I am able to use DataSOurce -->Add Power Bi Datset Connection and it works seemlessly from there.

AbhiSSRS_2-1618037745583.png

And If you want to use your local power BI dataset, then please open up your PBix file that contains the dataset on local and then copy the port name from DAX studio or local folder (you may find that on web how to get that) . Now use this to connect to "SQL Server Analysis Services" connection :

AbhiSSRS_3-1618038055196.png

 

AbhiSSRS_4-1618038112682.png

You are good to use your paginated with this datasource creating the datsets on this ! Only issue is that you will need to keep your PBIX running and also if you choose to close it /restart machine then change the datsource to new port/select new DB that appears on new Pbix open.

 

AbhiSSRS_6-1618038328362.png

 

 

Thanks!
Abhinav Singh

LinkedIn 

View solution in original post

16 REPLIES 16
AbhiSSRS
Solution Sage
Solution Sage

Hello @Amerikaner !

 

This works fine for me, I have worked with my power BI service hosted datsets connected live with a Premium per User workspace. It works the same way it works with Power Bi Desktop ,I only had to enable XMLA Read Write on my Power BI tenant .

AbhiSSRS_0-1618037414870.png

 

AbhiSSRS_1-1618037662724.png

I am able to use DataSOurce -->Add Power Bi Datset Connection and it works seemlessly from there.

AbhiSSRS_2-1618037745583.png

And If you want to use your local power BI dataset, then please open up your PBix file that contains the dataset on local and then copy the port name from DAX studio or local folder (you may find that on web how to get that) . Now use this to connect to "SQL Server Analysis Services" connection :

AbhiSSRS_3-1618038055196.png

 

AbhiSSRS_4-1618038112682.png

You are good to use your paginated with this datasource creating the datsets on this ! Only issue is that you will need to keep your PBIX running and also if you choose to close it /restart machine then change the datsource to new port/select new DB that appears on new Pbix open.

 

AbhiSSRS_6-1618038328362.png

 

 

Thanks!
Abhinav Singh

LinkedIn 

Hi Abhinav,

I really appreciate your assistance in trying to solve this problem! The good news is that I am able to successfully connect to the Power BI Desktop Dataset (see attached). The bad news is that I am unable to connect to the Power BI Service to connect to the Power BI Dataset in my Premium Workspace (see attached).  I have a pending case open on this issue with Microsoft and will update once it gets resolved. It has to be something on my end ... in the interim, you saved me a lot of time so I can proceed. Thanks again!!

 

DT 05.jpg

DT 06.jpg

 

DT 01.jpg

 

DT 02.jpg

DT 03.jpg

DT 04.jpg

@Amerikaner  Glad that could help! 
You may try runnig profiler on your dataset to see if the actual error is logged. The steps to run profiler are my article below in case you wish to debug this further! Maybe if you are able to post the actual error from the trace , the forum could help!

https://www.linkedin.com/pulse/run-profiler-power-bi-live-datasets-paginated-reports-abhinav-singh/

 

Hi Abhinav,

Thanks again for your quick response.  First, I went into my Data Source Credentials in the Premium Workspace, noticed invalid credentials and updated (see attached).

 

Pre - A.jpg

Pre - B.jpg

 

Second, I sourced the Workspace Connection from my Premium Workspace.

Step 01.jpg

 

Third, I opened SQL Server Profiler, File/New Trace and tried to connect to the Premium Workspace. See attached. 

 

Step 02.jpg

Step 03.jpg

Step 04.jpg

Step 05.jpg

As noted above, I was unsuccesssful. 

Hmm... This may be teh same reason that MS is investigating. 

Just to confirm you did select dataset in options?

AbhiSSRS_0-1618243255003.png

 

Step 06.jpg

I just now selected options and selected both default and then browse server.

 

Step 07.jpg

Step 06.jpg

Unsuccessful. 

 

 

Hmm... Lets leave it to MS then ! Please do post here what they find when this is resolved! 🙂

 

Thanks!

Hi Abhinav,

 

I found the solution and must give credit to Peter Myers (Bitwise Solutions) and Chris Finlan (Microsoft) as I followed their XMLA end point process from the Power BI Paginated Reports in a Day Series,Video #15 (Visualizing Report Data - Part 2, Begin Marker 1:20 | End Marker 2:30. 

 

Two discoveries: 1) Do Not Select "Add Power BI Dataset Connection", Do Select "Add Data Source", then Select "Microsft SQL Server Analysis Services" and 2) Under Data Source Properties / Credentials, Select "Do Not Use Credentials". This fixed the issue for me. Screenshots below.

 

Step 01.jpg

Step 02.jpg

Step 03.jpg

Step 04.jpg

Step 05.jpg

Step 06.jpg

  

Step 07.jpg

I do get this error only when I disable my XMLA Endpoint ReadWrite (which i guess you already have enabled)

 

AbhiSSRS_0-1618249701227.png

 

Alright this got on my nerves lol! Did some changes with Admin portal and got to replicate with another setting which makes sense! Please go and check if this too is enabled for your tenant! As I see your datasets are also from on-prem so below setting is required. 

 

AbhiSSRS_1-1618250892570.png

 

Please mark as solution if this is it! 🙂

 

Thanks!
Abhinav Singh

LinkedIn 

Hi Abhinav.

 

It was disabled. I enabled, applied and retested. Same errors 403/401. I will  try again later, if per chance, it needs more time to propogate the change. I will post the solution as soon as Microsoft evaluates the new tracers and let's me know. It's a authentication issue, they need to tell me from where. Thanks!

 

Step 08.jpg

Yes this takes 10 minutes to reflect! Did you retry after some time ?

I did retry (mutiple times) with the same outcome, unfortunately.

Amerikaner
Helper I
Helper I

Snapshot.jpg

Anonymous
Not applicable

There is no such limitation for using Power BI dataset from report builder. Can you share screenshots of what you are referring to?

Snapshot.jpg

Helpful resources

Announcements
Europe Fabric Conference

Europe’s largest Microsoft Fabric Community Conference

Join the community in Stockholm for expert Microsoft Fabric learning including a very exciting keynote from Arun Ulag, Corporate Vice President, Azure Data.

July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

July Newsletter

Fabric Community Update - July 2024

Find out what's new and trending in the Fabric Community.