Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
biki
Helper I
Helper I

On Premise Gateway Not Configured Correctly

hello, 

 

i have searched, but not found exactly the same issue.

we have on premise gateway (enterprise version) for years, abt 2 months ago, i moved the gateway to the other server. the migration process has succeed without any trouble at all. just like voila! the connection moved to the new one.

the gateway still running well actually, but this morning, i want to stop automatic refresh process for a while due to report update, turn out that Scheduled Refresh menu is disabled, 

 

PBI GW3.PNG and i checked the gateway is not configured correctly.

 

PBI GW.PNG

 

 

 

 

 

 

 

 

 

 

but when i checked the gateway setting, its online.

 

PBI GW2.PNG   PBI GW4.PNG

 

 

 

 

 

how to configure the gateway correctly then?

pls help, thanks in advanced!

 

 

2 ACCEPTED SOLUTIONS
biki
Helper I
Helper I

dear all, 

 

after a week trying to solve the problem with microsoft, finally i found what was the cause.

the problem is the version of Power BI Desktop, it need to be upgraded to the latest and choose the apps from Microsoft Store, and then republish all the reports.

after that, the enterprise gateway will work smoothly.

 

i consider this problem has SOLVED then.

 

thanks to all,

biki

View solution in original post

well, i just found out another solution, and i think Microsoft have to fix this bugs quickly.

 

last weekend there's some network migration in here, and this morning i've just realized that PBI gateway suddenly not connected (again).

1. first i tried to relogin the gateway, not worked, still not connected.

2. then i tried to update the gateway, relogin again, still not worked. the datasource has mapped but the button Apply still in disabled state 

3. accidently i clicked the status of the Gateway (the green one), suddenly the button Apply was enable!

biki_1-1665368370594.png

there, the solution has turned out so simple! is this because i updated the gateway? i don't know. 

is this solution applied in the first place? i don't know either.

the gateway is running, that's all that matters.

 

cheers!

biki

View solution in original post

21 REPLIES 21
biki
Helper I
Helper I

dear all, 

 

after a week trying to solve the problem with microsoft, finally i found what was the cause.

the problem is the version of Power BI Desktop, it need to be upgraded to the latest and choose the apps from Microsoft Store, and then republish all the reports.

after that, the enterprise gateway will work smoothly.

 

i consider this problem has SOLVED then.

 

thanks to all,

biki

Thank you for this hint! I had the same issue and issue got fixed by installing the Power BI Desk x86 instead of x64. Then I published my report again and the report is able to see the Data Gateway again... phew...

bcteh
Frequent Visitor

To upgrade PBI desktop and republish all the reports involved alot of work!

I knew this workaround from another thread, but still, why things break in the first place?

Is microsoft going to fix it?

well, i just found out another solution, and i think Microsoft have to fix this bugs quickly.

 

last weekend there's some network migration in here, and this morning i've just realized that PBI gateway suddenly not connected (again).

1. first i tried to relogin the gateway, not worked, still not connected.

2. then i tried to update the gateway, relogin again, still not worked. the datasource has mapped but the button Apply still in disabled state 

3. accidently i clicked the status of the Gateway (the green one), suddenly the button Apply was enable!

biki_1-1665368370594.png

there, the solution has turned out so simple! is this because i updated the gateway? i don't know. 

is this solution applied in the first place? i don't know either.

the gateway is running, that's all that matters.

 

cheers!

biki

v-jayw-msft
Community Support
Community Support

Hi @biki ,

 

What data source you are using?

Have you checked whether the user is correctly added to the gateway?

 

Best Regards,

Jay

Community Support Team _ Jay
If this post helps, then please consider Accept it as the solution
to help the other members find it.

hi v-jayw,

 

thanks for the response.

 

i'm using sql server datasource and usually worked.

i use the administrator access so it must be has the access, right?

 

the problem is, the gateway is online and ready to use as shown below.

 

PBI GW2.PNG

 

but in the datasets setting menu, the gateway connection is "not configured correctly", how do i configure correctly then?

 

PBI GW.PNG

 

i tried to create pbi report online using the same datasource, and it's also working well. so why there's a problem anyway? and how to fix that?

 

really need a help, thanks!

 

 

Anonymous
Not applicable

If the status shows not configured it means the Drivers and Configuration for that specific data source on the Gateway ( On-Premises ) are not configured. Below are the steps I would have done to ensure its correct : 
1) Go to Machine Gateway and then try to check the connectivity to the database. If you using DSN then ensure both 32 and 64 are installed and configured. 

2) Create a sample report just connection and some drag and drop and publish the report to the power bi service. 

3) Ensure in the Gateway ( Manage Gateway of the Power BI Service ) that the user who is logged in or trying to configure the connections has the right to do so.

 

Hope this helps. 

 

Regards

Mahak

hello Mahak, 

 

thanks for the answer, i will try the steps.

 

regards,

biki

hi Mahak, below the results:

 

1) Go to Machine Gateway and then try to check the connectivity to the database. If you using DSN then ensure both 32 and 64 are installed and configured. 

-- all the machines (gateway server, powerbi desktop server) all 64bit version

 

2) Create a sample report just connection and some drag and drop and publish the report to the power bi service. 

-- first i tried to create a simple report online based on existing dataset in powerbi.microsoft.com, it's worked well.

-- and today, i tried to delete all datasource from powerbi.microsoft.com, then refresh locally via powerbi desktop and republish it again.  i also recreated the gateway connection and added all datasets but still in datasource setting, it said gateway still not configured correctly.

 

3) Ensure in the Gateway ( Manage Gateway of the Power BI Service ) that the user who is logged in or trying to configure the connections has the right to do so.

-- for all the services, desktop, gateway, i only used my account (adminstrator access) so i think there's no issue here (gateway status is online, each of dataset status is also online) 

 

maybe another suggestion, pls?

thanks for your help!

 

regards,

biki

hello,

i tried over and over to re-map the datasource.

 

biki_1-1654506187167.png

but the button Apply still disabled. as far as i remember, the button will enabled right after we pick the related database in maps combobox. is this somekind of bugs or something?

 

can anyone help me with this?

 

thanks!

regards,

biki

 

 

bcteh
Frequent Visitor

same issue here! why is this happening suddenly?

yes, it happened so suddenly. 

 

microsoft, anyone?

finally, i tried to install personal gateway and it works!

at least for now

bcteh
Frequent Visitor

but thats not the right way i supposed?

yeah, at least while waiting for the bugs fixing (if there's any).

way much better than to refresh every single report manually and then publish it, everyday.

bcteh
Frequent Visitor

but why mark it as SOLVE when this is just a temporary FIX?

we could use personal gateway as long as we need, i think. and it quite help others with the same problem. 

bcteh
Frequent Visitor

do bear in mind that personal gateway cannot auto run or "run as service". 
meaning everytime you restart the pc/server, you will need to manually sign in your personal gateway.

thanks for your info @bcteh

hopefully our server will up 247 til we find the perfect solution for this issue.

 

we're still waiting for microsoft to response (i've already open ticket for this).

ROG
Responsive Resident
Responsive Resident

Hi @biki  I'm facing the same issue, and I was wondering if MS has replied to you?

Helpful resources

Announcements
Europe Fabric Conference

Europe’s largest Microsoft Fabric Community Conference

Join the community in Stockholm for expert Microsoft Fabric learning including a very exciting keynote from Arun Ulag, Corporate Vice President, Azure Data.

Power BI Carousel June 2024

Power BI Monthly Update - June 2024

Check out the June 2024 Power BI update to learn about new features.

PBI_Carousel_NL_June

Fabric Community Update - June 2024

Get the latest Fabric updates from Build 2024, key Skills Challenge voucher deadlines, top blogs, forum posts, and product ideas.

Top Solution Authors