Forum Discussion
OAuth2 credentials become invalid after successful update (Data Source Settings)
Hi, folks!
Credentials for one of the Data Sources that connects to Kusto become invalid after about an hour or so showing this message:
Then, I go ahead to Authentication Method, click on "Edit Credentials", select OAuth2 again, click on "Sign in", select my account from the pop up window, and then hit "Apply". After that, the Data Source Settings show connection successful. My reports refresh correctly either on demand or scheduled.
However, after some time, reports start failing to refresh again because the credentials are no longer valid in which case, I have to repeat the above steps again. This started to happen on March 7th, where all of our reports that depend on this data source started to fail during scheduled refresh.
Why my credentials become invalid? Any help is greatly appreciated.
Abe.
4 Replies
- abmate
Microsoft Employee
Thanks, GilbertQ !
Unfortunatelly, given my organization security policies it seems I cannot use the other authentication methods (i.e. Basic or Windows fail to connect for me). OAuth2 goes through two factor authentication first and that seems to work until credentials become invalid again 😞
This used to work fine until a few days ago. 😞