Forum Discussion

Anonymous's avatar
Anonymous
Not applicable
5 years ago

Not allowed to load dataflow into power bi desktop

The workspace is configured as per user to expediate the speed on refreshing dataflow with size around 35G.  Then I ran into below issues.

Here is the error information:

ProPlusInformationNotAllowedForNonProPlusCaller: ProPlusInformationNotAllowedForNonProPlusCaller
Details:
Error=ProPlusInformationNotAllowedForNonProPlusCaller
RequestId=2dc925a6-3dcc-4bec-a11b-3c6277af435d
RequestUrl=https://df-msit-scus-redirect.analysis.windows.net/metadata/v201606/cdsa/dataflows/0da163cc-d3b7-488f-ac5f-1fbc2597e90a/storageAccess

10 Replies

  • aj1973's avatar
    aj1973
    Icon for Community Champion rankCommunity Champion

    Hi Anonymous 

    Do you have a Pro License?

     

  • Anonymous's avatar
    Anonymous
    Not applicable

    Hi Anonymous ,

     

    I still could not reproduce your problem until now...It may be related to the environment, account number and many other factors.

     

    Please go to-->Data Source Settings-->Clear all permissions and restart the Power BI Desktop to have a try again.

     

    If you still cannot solve the issue,sorry for that, we do not found an effective solution.We suggest you go to https://powerbi.microsoft.com/en-us/support/ ,scroll down and click "CREATE SUPPORT TICKET" for further help if you are a pro user.

     

    Best Regards,
    Eyelyn Qin
    If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

  • Anonymous's avatar
    Anonymous
    Not applicable

    Hi Anonymous ,

     

    Did you CREATE SUPPORT TICKET for further help?and was your problem solve? If it is, kindly Accept it as the solution. More people will benefit from it.😀

    Thanks in advance.

     

    Best Regards,
    Eyelyn Qin

  • Anonymous's avatar
    Anonymous
    Not applicable

    I have Pro license and am currently testing the Premium Per User (PPU) license, but I get the same error:

    ProPlusInformationNotAllowedForNonProPlusCaller: ProPlusInformationNotAllowedForNonProPlusCaller
    Details:
    Error=ProPlusInformationNotAllowedForNonProPlusCaller
    RequestId=1234
    RequestUrl=https://wabi-north-europe-redirect.analysis.windows.net/metadata/v201606/cdsa/dataflows/1234/storageAccess

     

    This might have something to do with the Workspace that I assigned to premium (PPU), because I was able to connect to my other non-premium workspace.

     

    Update: If I remove the workspace from Premium PPU, then I am able to load the data. Interesting!

    • graemeg's avatar
      graemeg
      Frequent Visitor

      I am getting exactly the same issue.  I can't switch off PPU capacity in the Workspace as I am appending two datasets that are the output from 2 x API calls and the appending only works with PPU capacity Workspaces.  Very stuck and with something that should work.

      • Anonymous's avatar
        Anonymous
        Not applicable

        Did you remember to "ignore privacy levels"? You have to select all your queries in Power Query online and ignore privacy levels. It might help you out.

  • Anonymous's avatar
    Anonymous
    Not applicable

    Hi Anonymous ,

     

    Glad to hear from you that the issue has been solved by removing the workspace from Premium PPU.

     

    Could you please kindly Accept the reply as the solution? So that more people will benefit from it.Thanks😀

     

    Best Regards,
    Eyelyn Qin

  • Anonymous's avatar
    Anonymous
    Not applicable

    This seems to be an issue. As a workaround, I loaded the data into preview (in Power Query Online), then switchted PPU off. I then proceeded to load data into Power BI Desktop.