Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Earn a 50% discount on the DP-600 certification exam by completing the Fabric 30 Days to Learn It challenge.

Reply
Anytsirk12
Regular Visitor

Not able to add users to a data source as Admin

When clicking on "Manage Users" on a data source within my Power BI gateway, I have zero option to add new users. I am tenant admin and admin on the gateways. Where did this functionality move? Is it a temporary error/bug that Microsoft is resolving? Thanks for any help!

 

Current state: 

 

Anytsirk12_0-1695754358145.png

 


This is what I was expecting to see but no longer see:

Anytsirk12_1-1695754446055.png

 

 

1 ACCEPTED SOLUTION
calerof
Impactful Individual
Impactful Individual

Sorry to say it but, it works on my machine 🤔

What I checked is the following:

Figure 1Figure 1

When I see my localhost server with the Personal mode gateway I see the same as you, no option to share (Figure 1).

 

Figure 2Figure 2

Then when I chose the standard gateway I see the option to share, no problem (Figure 2).

Figure 3Figure 3

I checked my standard gateway and its status is online and I'm an admin (Figure 3).

 

Figure 4Figure 4

My standard gateway is online and all good to go (Figure 4).

 

Figure 5Figure 5

And lastly as final resource I checked that in the workspace I'm an admin also (Figure 5).

 

View solution in original post

6 REPLIES 6
GilbertQ
Super User
Super User

Hi @Anytsirk12 

 

On your second screen, you would type in the users name and then assign them the permissions and then click on Share to add them?





Did I answer your question? Mark my post as a solution!

Proud to be a Super User!







Power BI Blog

The second screen is from Microsoft's documentation, I don't have access to that second screen and I can't figure out why. 

calerof
Impactful Individual
Impactful Individual

Hi @Anytsirk12,

Have you tried to connect to the standard gateway, not the personal mode one?
Cheers,

F

The issue occurs on both personal mode and enterprise gateway data sources. 

calerof
Impactful Individual
Impactful Individual

Sorry to say it but, it works on my machine 🤔

What I checked is the following:

Figure 1Figure 1

When I see my localhost server with the Personal mode gateway I see the same as you, no option to share (Figure 1).

 

Figure 2Figure 2

Then when I chose the standard gateway I see the option to share, no problem (Figure 2).

Figure 3Figure 3

I checked my standard gateway and its status is online and I'm an admin (Figure 3).

 

Figure 4Figure 4

My standard gateway is online and all good to go (Figure 4).

 

Figure 5Figure 5

And lastly as final resource I checked that in the workspace I'm an admin also (Figure 5).

 

Thank you for providing your steps! I feel a bit foolish, looks like all the sources I was trying to add users to were Cloud sources that weren't run through a VNET gateway. Once I built a source on the machine that the enterprise gateway was on, I was able to see that manage user option. Thank you all again!!

Helpful resources

Announcements
LearnSurvey

Fabric certifications survey

Certification feedback opportunity for the community.

PBI_APRIL_CAROUSEL1

Power BI Monthly Update - April 2024

Check out the April 2024 Power BI update to learn about new features.

April Fabric Community Update

Fabric Community Update - April 2024

Find out what's new and trending in the Fabric Community.

Top Solution Authors
Top Kudoed Authors