Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
georgebagos
Regular Visitor

No gateway to access data source data-but working in PBI Desktop

I have created a report and have connected to another dataset of mine.

Desktop report works just fine and refreshes OK but when I publish it on the service I get a message that there is no gateway to access the data......

When trying to update the connection credentials I get no options.

 

Have looked everywhere and don't know how to fix this.

 

Any help please???

1 ACCEPTED SOLUTION

So,

 

I finally got it working.

I changed the query completely from the static excel to the same file in sharepoint and it worked.

 

Apparently you can't create composite models (and publish them on the service) using local files.

You can only use online files.

But did anyone know this before? 

 

A weekend well spent... : ))))

View solution in original post

7 REPLIES 7
djurecicK2
Super User
Super User

@georgebagos 

That makes sense- since the excel file is now part of the dataset, it's saying that you need a gateway now for the dataset. Are you able to put your excel file in OneDrive or OneDrive for business? If so, something like this might let you refresh on PBI service without a gateway:

https://radacad.com/change-excel-source-in-power-bi-to-onedrive-for-business-no-gateway-needed

Still did't work...

I have even deleted the excel file completely and published again but didn't fix the problem.

 

This makes no sense. When I click in data source credentials there are no options....

georgebagos_0-1669014512486.png

I read something about a "ghost" gateway being activated and I need to disable. Could that be it?

So,

 

I finally got it working.

I changed the query completely from the static excel to the same file in sharepoint and it worked.

 

Apparently you can't create composite models (and publish them on the service) using local files.

You can only use online files.

But did anyone know this before? 

 

A weekend well spent... : ))))

djurecicK2
Super User
Super User

Hey.

my data source is a dataset of my own.

so when I first published it the note on the service was that no gateway is needed as this source was already on the cloud.

but after adding a static excel to the file, all of the sudden I get a note saying that the cloud dataset can't be found. The message I get is like the picture here:

74E62408-BF32-495D-8322-59313FA3FA28.png


again the file was working just fine before on the service. The pbix file is also working as usual.

 

djurecicK2
Super User
Super User

Hi @georgebagos ,

 If you haven't already done it, you need to install and configure a Power BI gateway.

https://powerbi.microsoft.com/en-us/gateway/

Yes I have a gateway installed which works for other reports.

It shows as active running in my machine

but for this one when I go to source credentials I see no options.

Helpful resources

Announcements
July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

PBI_Carousel_NL_June

Fabric Community Update - June 2024

Get the latest Fabric updates from Build 2024, key Skills Challenge voucher deadlines, top blogs, forum posts, and product ideas.