Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Advocate III
Advocate III

Navigation builder - Link in content area gives error "refused to connect"

I have created a new link in navigation bulder, which is supposed to open in content area. When I open the link in app, I get error "refused to connect" and in upper left corner, I find another error message saying "This widget contains web content not provided by Microsoft. Web content could contain code with security or privacy risks."


I have tested this with several browsers and also our customer tested this with same result. If I change the link to open in same tab, it works, but that is not the good way of using it.

Resolver I
Resolver I

What works for me is to obtain the embedded URL 


Then copy the URL from src


And paste into 


The embedded URL removes the navigation panel of the workspace which the report resides in. The normal URL will include the navigation panel of the workspace which the report resides in. There will be a conflict if the report is reference from another navigation panel other than that of the workspace it resides in




Frequent Visitor

Hi all,

I've got the same issue.

When Microsoft will provide a relevant answer/solution ??

Advocate V
Advocate V

I had the same issue, I was trying to link to another Power BI report using the normal url but was getting errors. To solve my issue and get it to display in the content area, I had to get the emebed url for the report. Now it works seamlessly.

Not applicable

This solved our problem, thanks!

Not applicable

Same issue here.  Has anybody found a solution?  Link works if I choose to open in New Tab or Current Tab but not if I choose Content Area.

Not applicable

I have the same issue.  I want a PDF on a sharepoint to show in the content area rather than in the current or a new tab.  I know it is possible because Veolia have done it with an impressive demonstration as shown at a Power BI event by @AmirNetz  - (skip to 1:02.00 for the showcase and notice the 'Tutorial' and 'Documentation' parts.

What I currently get is my PDF appears for 1-2 seconds and then disappears but hovering the mouse over the grey content area gives a 'tooltip' of my document file name, so Power BI is recognising that it is there but not showing it.

Not applicable

@Anonymous  Have you got the solution on this?  I am facing the same problem.


The Veolia video is showing the Word Document in the 'Documentation' , which can be done by getting the embedded URL of Word document in SharePoint.


Still no clue on how to show PDF in content area

Community Support
Community Support

HI @MiraNi ,

As document said, current power bi not support to third party url. It will display security notice when you use third party link in it:

Publish an app in Power BI#considerations for using the new navigation builder option

A security warning is shown at the top of the embedded content to indicate the content isn't in Power BI.


Xiaoxin Sheng

Community Support Team _ Xiaoxin
If this post helps, please consider accept as solution to help other members find it more quickly.

I understand, it will show the security warning in left upper corner but it doesn't display the web page at all but gives the error message "xxxx refused to connect". I have tried with internal O365 -page, as it offers this link as a default and other web page. I only manage to get them open when having open in tab option.

Not applicable

Exactly the same issue here...

Helpful resources

July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

July Newsletter

Fabric Community Update - July 2024

Find out what's new and trending in the Fabric Community.