Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Earn a 50% discount on the DP-600 certification exam by completing the Fabric 30 Days to Learn It challenge.

Reply
debiagui
Helper II
Helper II

Meeasure Formating in a Lakehouse Semantic Model

I've a created around 10 measures in a Lakehouse, some of those measures are percentajes and other decimal numbers.

When I tried to change the formato of the percentaje or the decimal or any numeric format there's ni way to enable Thousand delimiter or decimal places, also is missing the Custom Formating.

All the configuration is missing, see the attathedSample2.PNGSample3.PNGSample1.PNG

 

But if you compare the same behaviour in a Datamart: Damart formating.PNG

3 REPLIES 3
debiagui
Helper II
Helper II

Still the same error now I can confirm this is an error in my Lakehouse @v-yifanw-msft can you take a look?

Or do I need to open a ticket?

v-yifanw-msft
Community Support
Community Support

Hi @debiagui ,

 

Based on your description, it appears that you are having difficulty applying thousands separators, decimal places, and custom formatting to metric values in Lakehouse. I would like to offer the following steps to troubleshoot and resolve the issue:

  1. Ensure that you are using the appropriate tool to set the formatting of the metric values. Formatting is typically done in a reporting tool such as Power BI Desktop, not in Lakehouse itself.
  2. Open the Power BI report connected to Lakehouse. Click the metric you want to format. You should be able to select the desired format from the Format drop-down menu. After selecting the format, you can specify the use of thousands separators and set the number of decimal places.
  3. If these options are available and effective in the data mart, but do not work in Lakehouse, it may be an indication that the Lakehouse semantic model needs to be restricted or a different approach taken.

If the above steps do not resolve your issue, it would be helpful if you could provide additional details, such as the version of Power BI Desktop you are using, or any error messages that appear when trying to set the metric value format.

 

Best Regards,

Ada Wang

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi @v-yifanw-msft , I'm not able to open the semantic model in Power BI.

Every time that I open a Semantic Model with Direct Lake in Power BI desktop fails, please take a look at this error: Partition partId of table 'TableName' may not oper... - Microsoft Fabric Community

* No other table area added to the model.

* Only Lakehouse tables in the model.

* Start creating the report in the service from the default semantic model.

* Then download the report and open in Power BI desktop and fails with the Partition error

In my case I'm using the Power BI version: 2.124.1554.0 64

And following with your request:

* no errors when I try to change the format

* It simlpe doesn't be enable

 

As workareounf I'm using Tabular Editor, but at the end I think is an issue in the Service

 

Helpful resources

Announcements
RTI Forums Carousel3

New forum boards available in Real-Time Intelligence.

Ask questions in Eventhouse and KQL, Eventstream, and Reflex.

MayPowerBICarousel

Fabric Monthly Update - May 2024

Check out the May 2024 Fabric update to learn about new features.

LearnSurvey

Fabric certifications survey

Certification feedback opportunity for the community.

Top Solution Authors