Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Earn a 50% discount on the DP-600 certification exam by completing the Fabric 30 Days to Learn It challenge.

Reply
SASN
Frequent Visitor

Measures created in Power Bi Desktop are not showing in Power Bi Service

Hi all,

 

I have a dataset with a live connection to my main_dataset. ( I will be creating several projects using this method connecting to the main_dataset which was created from a larger dataflow). I then have a report with visuals created in the dataset.

This has all been working correctly.

I needed to create some new measures, which I did in the main_dataset in Desktop.

When I refreshed dataset in Desktop, the new measures appeared as expected.

I then created visuals in dataset using these new measures and all appeared correct in Desktop.

After refreshing and looking in Power Bi Service, the new visuals created in dataset appear but display errors (see below), and the new measures are not showing in the dataset.

I have created simple test measures in the main_dataset in Desktop, but none are pulling through to Power Bi Service?

 

“Something’s wrong with one or more fields: (Data) ~WeekNumberNOW

Please try again later or contact support. If you need to contact support, please provide these details.

Activity ID: 9031cad6-0179-45bc-8f44-8662e3abe4fb

Request ID: eb16ee84-f038-9d69-6b6d-eae0ee9b3212

Correlation ID: 0722c6ed-59ce-1537-c3d0-b7cfa5386132

Time: Tue Mar 21 2023 16:11:20 GMT+0000 (Greenwich Mean Time)

Service version: 13.0.20295.61

Client version: 2303.2.12867-train

Cluster URI: https://wabi-north-europe-redirect.analysis.windows.net/”

 

I have just tested saving the dataset under a new name and uploading to Service, the missing measures are now showing in the new file which is great, but it would be better if I could fix the original due to retain people's shortcuts / subsriptions etc?

2 REPLIES 2
lbendlin
Super User
Super User

can you try with less exotic measure names?

SASN
Frequent Visitor

@lbendlin thanks, I have also tried with a measure called "TEST" but the outcome was the same.

After saving the file under a new name and uploading to service, everything appears to be working as expected with all of the original measures now showing.

 

Helpful resources

Announcements
RTI Forums Carousel3

New forum boards available in Real-Time Intelligence.

Ask questions in Eventhouse and KQL, Eventstream, and Reflex.

MayPowerBICarousel

Power BI Monthly Update - May 2024

Check out the May 2024 Power BI update to learn about new features.

LearnSurvey

Fabric certifications survey

Certification feedback opportunity for the community.

Top Solution Authors