Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

The ultimate Microsoft Fabric, Power BI, Azure AI & SQL learning event! Join us in Las Vegas from March 26-28, 2024. Use code MSCUST for a $100 discount. Register Now

Reply
Anonymous
Not applicable

Manage Permissions for Dataset in Workspace

Hi,

 

I am trying to remove user access to a dataset.

For users with permissions to "read, build" or "read, reshare, build" I have the option to "Remove reshare", "Remove build", "Remove access". However, for any users who have "App (build), reshare" permissions there is only the option to "Remove reshare".

To be honest I'm not really sure why there is any difference and what I can do to be able to remove access for these users. 

 

Any help is most gratefully received.

Thanks

1 ACCEPTED SOLUTION
MichaelOgaz
Advocate I
Advocate I

To remove the App (build) permission from the dataset you need to republish the app for that workspace and in the republish Permissions tab, uncheck the 'Allow all users to connect to the app's underlying datasets using the Build permission.' box.

View solution in original post

5 REPLIES 5
mybarbie9917
Frequent Visitor

I have the same issue. 

Some users have "App" permission with "Reshare" and "Build" options. 

mybarbie9917_0-1624389719784.png

Other users have "Read" (or "Build") permission with "Remove access" option. 

mybarbie9917_1-1624389846660.png

Why are there the differences among different users in Data Manage Permissions? What should I do to have "Remove access" option? 

annerator
Frequent Visitor

I was able to remove the build permission from the user.

 

Now when I log in as that user, the Export > Analyze in Excel option at the top is now greyed out which is good.

However, I can still export data from any of the report visuals by right clicking on the "..." for that visual and choosing "Export data". 

 

Is there any way to restrict the ability to export data from report visuals for specific users?

annerator
Frequent Visitor

Hey, that worked! Thank you. 🙂

annerator
Frequent Visitor

I'm struggling with this as well. I'm an Admin in the workspace.

  1. I updated the app for that workspace and in the republish Permissions tab, uncheck the 'Allow all users to connect to the app's underlying datasets using the Build permission.' box.
  2. I then went to the dataset for the report I want to restrict and clicked on the "..." to remove build permissions. 
  3. The only option I see is "Add Reshare". 

limited options.JPG

Any suggestions?

MichaelOgaz
Advocate I
Advocate I

To remove the App (build) permission from the dataset you need to republish the app for that workspace and in the republish Permissions tab, uncheck the 'Allow all users to connect to the app's underlying datasets using the Build permission.' box.

Helpful resources

Announcements
Fabric Community Conference

Microsoft Fabric Community Conference

Join us at our first-ever Microsoft Fabric Community Conference, March 26-28, 2024 in Las Vegas with 100+ sessions by community experts and Microsoft engineering.

February 2024 Update Carousel

Power BI Monthly Update - February 2024

Check out the February 2024 Power BI update to learn about new features.

Fabric Career Hub

Microsoft Fabric Career Hub

Explore career paths and learn resources in Fabric.

Fabric Partner Community

Microsoft Fabric Partner Community

Engage with the Fabric engineering team, hear of product updates, business opportunities, and resources in the Fabric Partner Community.

Top Solution Authors
Top Kudoed Authors