Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Register now to learn Fabric in free live sessions led by the best Microsoft experts. From Apr 16 to May 9, in English and Spanish.

Advocate II
Advocate II

Issue with Chiclet Slicer on online reports

Hi everyone, 


I have been facing a bug for the past few days with the chiclet slicer. 


I use it across my dashboards, and it works perfectly on the Desktop version. But once my reports are shared online, I have been noticing (and other users of my dashboards have been noticing the same) that the chiclet slicers are not working properly.


In fact, when I click on an element of the slicer, the visuals are not filtered accordingly (nothing happens). But when I click again on the same element of the slicer (to filter it out), then the visuals are filtered based on this element. This is very strange and it strongly alters user experience...


Any help would be appreciated 🙂





PS: I am using Chrome.


Edit: I've tried on Microsoft Edge: same problem.


Regular Visitor

I have the same problem. I just updated my version from  1.3.1 to 1.4.5 but still no update on that issue. 

Everything was fine 3 weeks ago, but something happened, the slicer does not work properly.

Incredible that this issue has not been fixed!


We are considering having to re-design all of our reports, but this is in no way a satisfying solution, especially considering the limitations of the other slicer/filtering options.

All - You MUST contact Microsoft directly. They are not going to come read every one of these threads. Open an SR via the Power BI Admin portal. There is strength in numbers and if we can convince them that this is a big enough issue, perhaps they will have more urgency to fix.

Advocate II
Advocate II

I still experience this issue! Do I need to update anthing or do something? Is it actually fixed?


This is a really annoying problem!

Post Patron
Post Patron

Same issue. Any fix yet?

To be honest, this is a utter embarassment on Microsoft's behalf. This issue was raised A MONTH AGO and yet nobody from Microsoft can even pinpoint the problem. How can such a fundamental issue not be picked up in UAT, and moreso, how can it still not be identified and rectified given the amount of complaints made.


Anyone from Microsoft care to elaborate? @v-yulgu-msft

Not applicable

Just wanted to post here and say that we are experiencing the same issue. It was first noticed after the September update and has not been resolved with the October update.


Come on, guys! At least give us an acknowledgement that there is an issue!

Frequent Visitor

Same issue is happening with our reports. Unfortunatly, my superiors are getting frustrated, because we are in the process of implementing the BI to the company. I hope this gets resolved soon.

It's not going to get fixed unless we all push. All I keep getting are "we will let you know whenever there is an update" to an issue that they have admitted is a known bug. Open an SR immediately. Having several of these open is the only hope of getting it fixed soon.

Advocate II
Advocate II

This is a really annoying bug. My clients are really unhappy about this. Does anyone one know whether this has been fixed or not?




Frequent Visitor

We are having the same problem.

It seems like a major BUG , especially when simple users don't understand this behavior and make decisions based on the wrong values Smiley Frustrated

did anyone get Microsoft to look at this ?


I opened an SR with Microsoft on this. I was told that it is a "known bug" but that they still do not have an answer. I would urge others to open an SR to keep the pressure up. You can do this from the Power BI admin portal.

Thanks @hannats


We've also submitted a Service Request so will wait to hear back about the issue.

Hi all,


It seems that this issue doesn't persist in my environment. I have tested this scenario in different versions of Desktop and on a different machine (2017 Sep, 2017 July). Please create a new report and re-publish it to service to check whether Chiclet Slicer can filter records correctly.


Best regards,
Yuliana Gu

Community Support Team _ Yuliana Gu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Creating a new report will do nothing to fix all of the current reports, so that doesn't help at all. Also it is random anyway - I have already seen it work in some reports and not others, so testing it on a new one proves nothing either way. If it is a KNOWN bug then it needs to be fixed. That is the only real solution.

I agree with @hannats!


@v-yulgu-msft We've republished reports and the issue still remains, but even if this were a fix to the problem it's not a viable solution to expect users to have to republish ALL their reports. We have 100+ reports and have been severly impacted by this issue, yet we're hearing mixed messages from Microsoft saying it is a bug vs it's not a bug can't be replicated.


The previous service update by Microsoft (PB118776) identified it as a caching issue for shared reports which has now been marked as resolved, even though complaints are submitted left, right and centre stating the issue firmly remains.

Advocate II
Advocate II

We are having the same issue. This is really a big problem. Also I tried republishing and that did NOT fix anything. Even tried removing the custom visual from my PBIX file altogether and re-installing the latest version then recreating the visuals, but that also did nothing to fix the issue.


Hi @AxelPrunier,


I could reproduce this problem in my environment. But after I remove and re-publish the .pbix file to service, the Chiclet Slicer works fine on online report. I have tested this scenarion in IE edge and Chrome.


So, please try to re-publish your Power BI report to service to see whether it works.


Yuliana Gu

Community Support Team _ Yuliana Gu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

I've tried downloading, saving, republishing - same thing. I've unistalled PBI Desktop and reinstalled. Then re-downloaded and re-published. Same issue. My visuals are absolutly worthless right now. I'm beyond frustrated. I and several others rely on this report for daily business use.. Please take care of this. 

@kendalllister @vanessa @jbaideme I'm just an end user like you. I've just rechecked our chiclets and they are working AOK on powerbi desktop and powerbi service. Are you all using the May release of PowerBI desktop as that was when our problems were fixed? Are you using service or are you using on-prem reports server? If you are stuck change to using basic slicer... or try using the “?unmin=true” parameter at the end of your report url. Fnally, always log a job with Microsoft Support



The reports were published with the June release of Power BI Desktop. 


But, I uninstalled the June version and re-installed and published the reports with the May version. The issue still exists (grid, card, muti-row card visuals keep loading).


For now, I am using the basic filter available and everything works fine.





Helpful resources

Microsoft Fabric Learn Together

Microsoft Fabric Learn Together

Covering the world! 9:00-10:30 AM Sydney, 4:00-5:30 PM CET (Paris/Berlin), 7:00-8:30 PM Mexico City


Power BI Monthly Update - April 2024

Check out the April 2024 Power BI update to learn about new features.

April Fabric Community Update

Fabric Community Update - April 2024

Find out what's new and trending in the Fabric Community.

Top Solution Authors
Top Kudoed Authors