Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

The ultimate Microsoft Fabric, Power BI, Azure AI & SQL learning event! Join us in Las Vegas from March 26-28, 2024. Use code MSCUST for a $100 discount. Register Now

Reply
AxelPrunier
Advocate II
Advocate II

Issue with Chiclet Slicer on online reports

Hi everyone, 

 

I have been facing a bug for the past few days with the chiclet slicer. 

 

I use it across my dashboards, and it works perfectly on the Desktop version. But once my reports are shared online, I have been noticing (and other users of my dashboards have been noticing the same) that the chiclet slicers are not working properly.

 

In fact, when I click on an element of the slicer, the visuals are not filtered accordingly (nothing happens). But when I click again on the same element of the slicer (to filter it out), then the visuals are filtered based on this element. This is very strange and it strongly alters user experience...

 

Any help would be appreciated 🙂

 

Thanks.

Axel

 

PS: I am using Chrome.

 

Edit: I've tried on Microsoft Edge: same problem.

 

93 REPLIES 93
jimgreene
Frequent Visitor

Team,

 

Something changed for us yesterday in the PBI Service. Button text that used to fit perfectly within a chicklet no longer does. It is still fine in the PC version, but not the service. Increasing chicklet width helps a little, bit it appears what really needs to be done is increase the width of the entire box holding the chicket, which is not possible for most of our reports because they have been precisely designed for everything to fit on the page.

 

It's like the PBI service is not correctly rendering the text so it doesn't fit like it used to.

 

An example from the PC view:

 

jimgreene_0-1708029857027.png

 

 

Same but from the service view:

 

jimgreene_1-1708029857028.png

 

 

The service view used to be just fine. Nothing was changed to make the text stop showing correctly.

 

How do we go about getting this fixed? We have dozens of reports with buttons that don't show correctly and in some cases are unuseable because you can't read enough of the text to make the correct choice.

 

Thanks!

 

jim

wx5558284
Frequent Visitor

Hello, 

 

I got a strange issue that the chicklet is not filtering for default value when refresh the browser. Chicklet filter is working for entering the report or switching between pages, but if you refresh the browser the chicklet shows filtered but other visuals in the page is showing all dat.

I'm using the Desktop Jan 2018 and chicklet imported from store.

 

Capture.PNG

Anonymous
Not applicable

We are experiencing the same issue. It seems whenever a new version of desktop is published the chiclet slicer has a new issue. We had to remove the chiclet slicers despite everyone loving them because they just break too often. 

@Anonymous, @todea, @wx5558284 Please add ?unmin=true as query parameter to the end of URL string, and let me know if the bug is gone.

Nikita Grachev,
Team Leader
Microsoft Power BI Custom Visuals,
pbicvsupport@microsoft.com

I have report with Chichlet slicer and its working fine with NTLM or basic auth but when we tried using custom auth we are getting the issue.

This is a long frustrating one.  Unfortunately, the query string parameter ?unmin=true doesn't seem to be helping in our case...

@bigbrownboy sorry to hear that but @nikitagrachev has been very helpful. He provided support through formal microsoft channels and provided a workaround version of the chicletslicer that applied the filter twice with a short delay. Issue seemed to be with report loading slowly and chiclet applying too soon to work. It was supposed to be fixed in the April release but still remains an issue for us and we have referred it back to Microsoft Support. I encourage you to log it formally but i will try to remember to update this thread when resolved.

@nikitagrachev yeah, still doesn't work for us (and tried the query string parameter).  What @todea describes as the root cause makes sense.  In our report, half of the visuals tied to the chiclet are correct on load and half are not.  

 

I can open up a support case on this if it makes sense to.

@bigbrownboy, are you checking ChicletSlicer in Desktop app or in WebService?

Nikita Grachev,
Team Leader
Microsoft Power BI Custom Visuals,
pbicvsupport@microsoft.com

@nikitagrachev Desktop it is fine. It’s on initial load in the web service where visuals come out of synch with it.

@bigbrownboy this is the same problem for us, fine in desktop issue appears when published in service.

@nikitagrachev Did the fixes you've mentioned make it into the March release of Power BI Report Server? We are experiencing a similar problem to that described here, i.e. on loading a report the chiclet's filters are not applied to the data, but after a refresh they are. This is confusing for our users.

@kendalllister, yes filters chiclet's filters bug should be fixed in March release of Power BI Report Server, have you tried to upgrade it to March release?

Nikita Grachev,
Team Leader
Microsoft Power BI Custom Visuals,
pbicvsupport@microsoft.com

Yes, we are running the March release but still experiencing the same symptoms as @bigbrownboy and @todea, i.e. the selected filters in chiclets aren't applied when the report is loaded on the Report Server web interface.

@kendalllister @nikitagrachev we haven't yet received advice that this issue has been resolved in the current release. We were told April release and tested it but it didn't work. Apaprently, the (Australian) PowerBI service was out of sync but we tried again and it still didn't work and so we were told the May release would contain the fix? We have not yet updated to May to test as we are waiting on confirmation.

@nikitagrachev am pleased to report that chiclet slicer issue has been resolved in the May version release of PowerBI and update to the powerbi service. Thank you to all involved in this case from its beginning to this end.

@nikitagrachevCan you confirm when this fix will be available to on-premises customers?

I am facing the same issue with a report in which chiclet slicers have been used. 

 

 

@bigbrownboy, the bug with ChicletSlicer had been fixed last month, does not it still work for you?

Nikita Grachev,
Team Leader
Microsoft Power BI Custom Visuals,
pbicvsupport@microsoft.com

Hi @nikitagrachev yes that does work using the app.powerbi.com service however our reports are consumed by embedding the reports in our sharepoint environment so we won't be able to add that parameter e.g. our embedded link within our sharepoint page would call: "https://app.powerbi.com/reportEmbed?reportId=ac63e87a-ae7b-475e-8070-8cdda1a00fc2&groupId=727288...". Any thoughts on how we could get the embedded link to include that parameter? Thanks, Tim

Helpful resources

Announcements
Fabric Community Conference

Microsoft Fabric Community Conference

Join us at our first-ever Microsoft Fabric Community Conference, March 26-28, 2024 in Las Vegas with 100+ sessions by community experts and Microsoft engineering.

February 2024 Update Carousel

Power BI Monthly Update - February 2024

Check out the February 2024 Power BI update to learn about new features.

Fabric Career Hub

Microsoft Fabric Career Hub

Explore career paths and learn resources in Fabric.

Fabric Partner Community

Microsoft Fabric Partner Community

Engage with the Fabric engineering team, hear of product updates, business opportunities, and resources in the Fabric Partner Community.

Top Solution Authors
Top Kudoed Authors