Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

The ultimate Microsoft Fabric, Power BI, Azure AI & SQL learning event! Join us in Las Vegas from March 26-28, 2024. Use code MSCUST for a $100 discount. Register Now

Reply
picander
Advocate I
Advocate I

Issue - Enable to use service "Preparing Power BI" Loop after Login (external-tenant)

I am experiencing some issues after login in a multi-tenant scenario.

 

Scenario:

- User 1 in Tenant A (Premium per User license in Tenant A)

- Login as User 1 (External Azure AD B2B Guest) in tenant B (Premium per User Workspace), using an URL like

https://app.powerbi.com/home?ctid=4xxxxxxxxxxxxxxxxxxxxxxxxxx6 

- Getting first the message "You've selected Microsoft Power BI" - with "You already have a license for Microsoft Power BI"

picander_0-1678190472572.png

- Redirect to app.power.bi but getting a looping redirect message with "Preparing Power BI".

https://app.powerbi.com/PleaseWait?ru=xxxxxredirectedFromSignup%3D1%26language%3Den-US&redirectedFro... 

picander_1-1678190656824.png

I tried to access several links / urls the resources (Reportip) with no success - there is always a redirect starting with the message "Preparing Power BI".

Internal user to the organisation (Power BI Admins) can however access the power BI service in their tenant.

It is currently unpossible to use the service as an external user in my scenario.

 

I tried it on several browser, after a reboot, and also on several machines - same results.

 

Any ideas how to fix this? Is it a temporary bug on the service?

 

Other issues - out of subject, but another issues some user are experiencing in our multi-tenant scenario is the message "Sorry, we couldn't find your app" when accessing an application in an external tenant.

 

It seems to exist some issues with login on multi-tenant scenarios...

1 ACCEPTED SOLUTION
MM_One4
Frequent Visitor

Hi @picander,

I believe we solved the issue, although I still need to figure out exactly why it would be an issue. We noticed a difference between the users in ADD that were able to access the report and the users that ran into this looping crediential issue.

In Azure AD, these external users were either marked as a "Member" or "Guest" user type. The external users that were marked as "Member" seemed to be running into the looping credential issue, but those marked as "Guest" user type in AAD were able to access the report as expected. 

We updated the user properties in AAD for the external users marked as "Member", and immidiatly they were able to login successfully and view the report. Not sure exactly what is going on yet that causes the "Member" user type to cause this issue, but it must have something to do with the double tennant... If we find out more details around the cause of this issue, I will update this thread. Thanks!

View solution in original post

4 REPLIES 4
MM_One4
Frequent Visitor

Hi @picander,

I believe we solved the issue, although I still need to figure out exactly why it would be an issue. We noticed a difference between the users in ADD that were able to access the report and the users that ran into this looping crediential issue.

In Azure AD, these external users were either marked as a "Member" or "Guest" user type. The external users that were marked as "Member" seemed to be running into the looping credential issue, but those marked as "Guest" user type in AAD were able to access the report as expected. 

We updated the user properties in AAD for the external users marked as "Member", and immidiatly they were able to login successfully and view the report. Not sure exactly what is going on yet that causes the "Member" user type to cause this issue, but it must have something to do with the double tennant... If we find out more details around the cause of this issue, I will update this thread. Thanks!

This was indeed the solution we found - without really understanding how it works as well...

picander
Advocate I
Advocate I

Hi! 

 

The issue resolved itself - I presume this was a bug in the service...

The multi-tenant experience in PBI is still terrible. I would advise to use strictly different browsers / profiles per tenant. 

 

Keep us updated if you found the reason for this behaviour!

MM_One4
Frequent Visitor

Hi picander,

I realize this is months down the road from when you first raised this issue, but were you have to solve for this? I am running into the exact same error in our organization today. 

Thank you 

Helpful resources

Announcements
Fabric Community Conference

Microsoft Fabric Community Conference

Join us at our first-ever Microsoft Fabric Community Conference, March 26-28, 2024 in Las Vegas with 100+ sessions by community experts and Microsoft engineering.

February 2024 Update Carousel

Power BI Monthly Update - February 2024

Check out the February 2024 Power BI update to learn about new features.

Fabric Career Hub

Microsoft Fabric Career Hub

Explore career paths and learn resources in Fabric.

Fabric Partner Community

Microsoft Fabric Partner Community

Engage with the Fabric engineering team, hear of product updates, business opportunities, and resources in the Fabric Partner Community.

Top Solution Authors
Top Kudoed Authors