Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
SHHargrove
Advocate II
Advocate II

Interactions suddenly working incorrectly.in the Service

We are using a bar chart of products to filter several other visualizations on the page.  The bar chart shows data for only one month (Visualization Filter is set to a specific month).  Te other visualizations show time trends (several months of data) for the selected product(s).  Since the latest update, the PowerBI service is now applying the single month filter to the other visualizations as well as applying the product filter.  This, of course, renders the time trend graphs meaningless.   The desktop works as expected, but the Service does not.

 

Is this a new "feature" we need to work around or is a bug that can be fixed?

1 ACCEPTED SOLUTION
greggyb
Resident Rockstar
Resident Rockstar

Definitely a bug. Visual-level filters are (supposed to be) explicity scoped to a single visualization, as the name implies. Brushing and linking should only be based on the currently selected axis category.

 

I'm able to reproduce the behavior you're seeing in the service.

 

Edit: Apparently the community forums are the official bug report medium for Service bugs now.

 

Repro steps:

  1. Create a bar or column chart, chart1, with any category as the axis label, and some measure on values
  2. Create a second chart, chart2, with months as the axis label and some measure from the same fact table on values
  3. Add month as a visual-level filter to chart1
  4. Apply a filter on chart1's visual-level filter to a single month
  5. Select any bar/column in chart1
  6. Observe chart2 being filtered to only the month in chart1's visual level filter

Edit2:

Confirmed identical behavior for chart1 as any column or bar chart (stacked, clustered, combos, waterfall), pie, donut, funnel, or treemap and chart2 as any visualization.

View solution in original post

8 REPLIES 8
greggyb
Resident Rockstar
Resident Rockstar

Definitely a bug. Visual-level filters are (supposed to be) explicity scoped to a single visualization, as the name implies. Brushing and linking should only be based on the currently selected axis category.

 

I'm able to reproduce the behavior you're seeing in the service.

 

Edit: Apparently the community forums are the official bug report medium for Service bugs now.

 

Repro steps:

  1. Create a bar or column chart, chart1, with any category as the axis label, and some measure on values
  2. Create a second chart, chart2, with months as the axis label and some measure from the same fact table on values
  3. Add month as a visual-level filter to chart1
  4. Apply a filter on chart1's visual-level filter to a single month
  5. Select any bar/column in chart1
  6. Observe chart2 being filtered to only the month in chart1's visual level filter

Edit2:

Confirmed identical behavior for chart1 as any column or bar chart (stacked, clustered, combos, waterfall), pie, donut, funnel, or treemap and chart2 as any visualization.

I have submitted a Frown on this twice -- once for the service and then later when the same behavior appeared in the desktop.  So far it hasn't been fixed.  I've seen no acknowledgement that it is a big.  I've had no indication that anyone saw the frown.


This is really hurting a number of existing in-production dashboards.

I'm having to pull back deployment to potentially hundredss of users because of this.

How can I get some feedback/action on it?

@SHHargrove Have you submitted and actual ticket, or just used frowns?

https://powerbi.microsoft.com/en-us/support/ Contact Support (bottom right) -> Under Basic Support - bottom right "Submit a Ticket"

This will open an actual ticket number with MS support.


Looking for more Power BI tips, tricks & tools? Check out PowerBI.tips the site I co-own with Mike Carlo. Also, if you are near SE WI? Join our PUG Milwaukee Brew City PUG

Thanks. I have now submitted a support case in the O365 Admin / support site.  Got a ticket number.

I'm surprised there isn't a lot more message traffic about this issue.  Surely we're not the only ones it affects.

 

Did you get a resolution to this issue?  I have submitted a ticket as well, but the problem is not yet resolved for me.

I added an IDEA : Visual Interactions should not include Visual Filters

Voting would be good.

Just this morning I received a reply -- the behavior is by design.  Not a bug.

I'm trying to figure out the best way to signal my great disappointment.

Thanks for the tip.  Submitted.

Helpful resources

Announcements
PBI_Carousel_NL_June

Fabric Community Update - June 2024

Get the latest Fabric updates from Build 2024, key Skills Challenge voucher deadlines, top blogs, forum posts, and product ideas.