Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
Anonymous
Not applicable

Information is needed in order to combine data

 I am getting this error message when refreshing (manually or via schedule) on Power BI service. This happened initially on a complex data model but I narrowed it down to being and issue with combine queries.

 

I simulated another example with just 2 tables from 2 databases on the same SQL server. Both tables are appended. All works well on desktop but refresh fails on service.  

 

The gateway is installed and has always worked (and still works on other reports that do not use merging/appending queries). 

 

I have tried all combinations possible with the privacy settings with no success

 

From other recent posts I understand I am not the only one to have this issue. 

 

For info, I do not think that it is the merging itself that causes the problem. I tried with 2 Excel tables on a SharePoint site and that worked just fine. 

 

Christine

2 ACCEPTED SOLUTIONS
v-qiuyu-msft
Community Support
Community Support

Hi @Anonymous,

 

Please download the report and open it in Power BI desktop, go to Query Editor, refresh data to see if any message pops out. Also please go to the Data Source Settings, click on Edit Permission for these two data sources points to two databases, ensure both privacy level is Organizational. 

 

Then republish the report to Power BI service, go to Manage Gateways, ensure Privacy Level for these two SQL data sources is Organizational as well. Then refresh the dataset again. 

 

Best Regards,
Qiuyun Yu 

Community Support Team _ Qiuyun Yu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

Anonymous
Not applicable

Hi @v-qiuyu-msft,

 

Thank you so much, you solved my problem. The issue was at the Manage Gateways, the privacy level was "Private". I couldn't modify the existing datasource but could delete it and re-create it with the correct settings. 

Your help is really appreciated. 

 

Kind Regards,

Christine

View solution in original post

29 REPLIES 29
andyclap
Advocate II
Advocate II

A lot is explained by this article https://www.alphabold.com/data-privacy-settings-in-power-bi/

 

Annoyingly the settings are independent betwen PowerBI desktop, and the PowerBI service, so you have to make sure to set it in both.

 

I think the documentation around this in Microsoft could do with some improvement - it certainly tripped me up.

Screenshot 2024-06-11 115104.png

Yes, need to update Privacy Level in both Power BI desktop file and in Power BI Service.

There is one data source in Power BI Service which privacy level was "None", as soon as I switch to "Organizational", the refresh works as intented. Thanks for the help.

diogofdasilva
New Member

Coloca como public que vai (Y)

DanielHart
Frequent Visitor

If anyone is still having this same error, then I have another thing for you to check.

 

I was having the same problem as everyone else, I had the privacy setting to Organizational on all queries, but still got the error.

 

It turned out to be that I had a query with Encrypt connections selected (unintentionally). Deselected this and re-published to PowerBI service and it worked.

 

DanielHart_0-1630051075035.png

 

 

Anonymous
Not applicable

Mine is also the same case. It just said 'More Information Needed'.
My connections are:
1. AsAzure
2. SharePoint
3. PowerBI Dataflow

All of the privacy levels are set to - Organizational. 

Tried different workspaces/ different combinations. 
On PowerBI Desktop it works fine but fails again on Service. On Service - all the credentials are set-up, no Gateway used, Privacy level settings are all 'Organizational'. It still fails... 
This issue is quite random. I faced the same for some of my reports earlier (2 weeks ago).

Please help and let us know the rrot-cause as well as this is totally a grey area 🙂 .
Re: Has anything changed in Power BI Service? All ... - Microsoft Power BI Community

Anonymous
Not applicable

Hi Rushkie, I ran into the same problem. For me the problem started two days ago. For some reason the datasets will still refresh in a certain workspace. This can be due to the fact that this is a premium capacity workspace, or simply that the dataset and dataflow are in the same workspace. Still trying to figure out what causes it exactly.

v-qiuyu-msft
Community Support
Community Support

Hi @Anonymous,

 

Good news. Smiley HappyAs the issue is resolved, I will close this thread. 

 

Best Regards,
Qiuyun Yu 

Community Support Team _ Qiuyun Yu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

This is not resolved. Still having this issue. We are using premium capacity and still encounter this issue.

@v-qiuyu-msft 

I have the same problem

I combine 3 queries from APIs and get the same error

Each query is running fine separately

I have Organizational Privacy level

and I have Ignore Security option checked

I don't have a Gateway since it's APIs from the cloud

Please help!

Thanks

Michael

Message:Information is needed in order to combine data Table: ACCOUNTS_UNION.
Cluster URI:WABI-WEST-EUROPE-redirect.analysis.windows.net
Activity ID:47507ca3-341a-4619-96ce-23236dffc7a4
Request ID:af71938c-b45a-9845-5792-90cc300416b0
Time:2019-02-15 18:03:42Z

I have spent 4 hours on this and I have narrowed the problem to one query

When I use it in Append - it causes the error

But the error is only in the service!!!!
Desktop is ok

There are no errors in the query itself and it loads OK by itself

DataSource is almost the same as the other two queries with just a slight difference in url

but the same Organizational Privacy and the same Basic authentication

Please help! @v-qiuyu-msft 

Thanks

Michael

Anonymous
Not applicable

Hi Michael,

So you publish to the online service, correct?

In my case the settings that were wrong were settings in the datasource on the online service. Desktop works well but when I published it to the service, it stopped working, generating the error message. 

 

For info, there are these settings within desktop (I think there are two) AND the setting on the Power BI online service that need to match each others. 

 

To fix it I :

  1. went to Power BI online,
  2. expanded the workspace with the faulty dashboard,
  3. in the section "Datasets" I clicked the ellipsis (3 dots) next to the dataset that had the issue,
  4. then option "Schedule Refresh".
  5. Expand the "Gateway connection" group
  6. click the "Actions" cogwheel (for info, there are other ways to get to the same point, this is just one).
  7. On the left hand side, open the Gateway cluster group and select the connection that has the issue. 
  8. There you will find the Authentication Method that seems to be the causing the trouble. As I said in my post, I could not alter an existing one to give it the appropriate settings, but it was easy enough to create a new one with the correct setting. 

As far as I remember, that was all that was required to fix it. 

 

All the best

 

@Anonymous 

Thanks a lot Christin!

The problem is that I don't have a Gateway...(I don't need it since my data is from API)

I have talked to Microsoft Support and they tryied several things (delete dataset), publish to My workspace, and I also triple-checked my credentials

So somehow it is working now (I am still not sure what fixed it)

Thanks a lot!

Michael

Anonymous
Not applicable

I have the same problem, I don't have a gateway but I already put the data sources as organizational, but in the same way it gives me this error

"Information is needed in order to combine data;Information about a data source is required.. The exception was raised by the IDbCommand interface. Table: NPIDataSource"

If I refresh the data in PB desktop it doesn't give me an error, but in PB web it does

Having the exact same problem apart from the fact that my refreshes do NOT work 🙂

Did you ever find out what the problem was?

@Yggdrasill You must make sure that in 'Power BI desktop > Data source settings > Edit permissions' section the Privacy level for all the sources that make up the query merge or append, is set at 'Organization' level 

 

Then, when you upload the file to PBI Service, either in the gateway credentials section, or if they are cloud sources, then just in credentials section, click edit credentials and there make sure that all sources involved in the merge or append actions are set at organization privacy level.

 

With these two places set up identical to each other then you should be able to succesfully refresh the dataset

@Rigensis THANK YOU.

 

I've been trying to solve this for the better part of two days without success. Only affected the appended query and its components.

 

There's tons of google results on variations of this error and none of them worked. Your steps above fixed it in like 60 seconds.

 

Over 2 years later. Thanks again!

Anonymous
Not applicable

Hi @v-qiuyu-msft,

 

Thank you so much, you solved my problem. The issue was at the Manage Gateways, the privacy level was "Private". I couldn't modify the existing datasource but could delete it and re-create it with the correct settings. 

Your help is really appreciated. 

 

Kind Regards,

Christine

v-qiuyu-msft
Community Support
Community Support

Hi @Anonymous,

 

Please download the report and open it in Power BI desktop, go to Query Editor, refresh data to see if any message pops out. Also please go to the Data Source Settings, click on Edit Permission for these two data sources points to two databases, ensure both privacy level is Organizational. 

 

Then republish the report to Power BI service, go to Manage Gateways, ensure Privacy Level for these two SQL data sources is Organizational as well. Then refresh the dataset again. 

 

Best Regards,
Qiuyun Yu 

Community Support Team _ Qiuyun Yu
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Thank's! it really works

Anonymous
Not applicable

This solution didn't works for me, the error mssage persist: 

 

Amf_91_0-1667566931547.png

I've tried all the privacy levels in desktop and online power bi but the error message continues. The Oracle connection is made through gateway. Is there any other solution that could solve the problem? 

Thank you

Helpful resources

Announcements
Europe Fabric Conference

Europe’s largest Microsoft Fabric Community Conference

Join the community in Stockholm for expert Microsoft Fabric learning including a very exciting keynote from Arun Ulag, Corporate Vice President, Azure Data.

July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

July Newsletter

Fabric Community Update - July 2024

Find out what's new and trending in the Fabric Community.