Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
adriansuteu
Advocate I
Advocate I

Information is needed in order to combine data error even with same Privacy Levels in Desktop/Server

Hello.

 

I get the following error when trying to refresh a report on PBI Server:

 

There was an error when processing the data in the dataset.

Please try again later or contact support. If you contact support, please provide these details.

  • Data source error{"error":{"code":"ModelRefresh_ShortMessage_ProcessingError","pbi.error":{"code":"ModelRefresh_ShortMessage_ProcessingError","parameters":{},"details":[{"code":"Message","detail":{"type":1,"value":"Information is needed in order to combine data"}}],"exceptionCulprit":1}}} Table: PBI_WagesCat.
  • Cluster URIWABI-US-NORTH-CENTRAL-redirect.analysis.windows.net

 

Refresh works fine on Desktop app. There are no error messages. Also, I made sure that both Desktop and Server have the data sources set to the same Privacy Level: Organizational. I triple checked that. My data source are some Excel files stored on OneDrive for Business so in PBI they qualify under Web source type.

I mention that I have just updated my Power BI Desktop version with this new one with the fancy ribbon before downloading (a long time not used report). I edited that report and then overwrite the old one.

I have also tried to delete the report from Server and Publish it then as a new report and I get the same error.

 

Can you please help me?

 

Thank you,

Adrian

 

22 REPLIES 22
coldjpint
New Member

Had same issue.  Following steps worked:

1. Delete Report and Dataset from published app.  Republish App.

2. Clear Cache on PBI desktop file (mentione earlier).  Update Privacy settings to a value other than None.  Should match on both data sets.

3. Refresh locally to ensure no Privacy errors/warnings.

4. Publish to Power BI app.

5. Ensure that Credentials for both data sources use the same privacy settings (set in step 2).

 

 

It works. Thank you!

jashjacob
Helper I
Helper I

I am getting this issue today, on reports that worked until last week. All the solutions mentioned are either not relevant to me or not working for me.

piotrek
New Member

I have similar error and none of the step in the thread helped:

 

Data source error{"error":{"code":"ModelRefresh_ShortMessage_ProcessingError","pbi.error":{"code":"ModelRefresh_ShortMessage_ProcessingError","parameters":{},"details":[{"code":"Message","detail":{"type":1,"value":"Information is needed in order to combine data"}}],"exceptionCulprit":1}}} Table: NEW table.

 
Jmenas
Advocate III
Advocate III

Hi all,
@adriansuteu  I could fix it. It is a reference problem that you might have. If you are appending or combining two or more tables you should do it in a new query instead of the main query. That solved the issue for me.

 

Best,

Jorge

@Jmenas  I was experiencing the same exact issue as many others in this thread. I took your advice, and rebuilt my report by merging my queries as NEW. This seems to have solved this issue for me.
Even though the process of doing this was not fun as I had do rebuild a number of tabs and visulaizations in my report, the automatic refresh is now working. This was a good lesson for me to never merge or append queries to exisiting tables but rather always merge or append as NEW.


Thanks for your suggestion. 

@Jmenasthank you for your suggestion.

 

I have modified that query and created it as a brand new append query. This is the result:

 

let
Source = Table.Combine({PBI_WagesCat_appended, PBIDIm_CostPersonCat_new}),
#"Filtered Rows" = Table.SelectRows(Source, each ([Cont] <> null))
in
#"Filtered Rows"

 

I have republished the report and hit refresh in PBI Service. After making sure that the same level of privacy is set. Result: another table gave me the same error (built in the same system, with information appended to the intial table). Fixed it in the same way, then another table gave me the error, I fixed this one too.

 

But at the end I got the error for one of the tables I just fixed. Same error message. This is the query for the table that gave me the error last time:

 

let
Source = Table.Combine({Salary_appended, #"Costs-Employee-2018_new", #"2018_IndirectCosts", #"Salary&CostPerPerson_Real", GlobalCost_Real_Indirect}),
#"Changed Type1" = Table.TransformColumnTypes(Source,{{"End Date", type date}, {"C-TKI-Tenders", type number}, {"C-TKI-Online", type number}, {"C-TKI-Partnership", type number}, {"C-TKI-International", type number}, {"C-CP", type number}, {"C-RO", type number}, {"C-CPTI", type number}, {"Expense category", Int64.Type}}),
#"Unpivoted Only Selected Columns" = Table.Unpivot(#"Changed Type1", {"C-TKI-Tenders", "C-TKI-Online", "C-TKI-Partnership", "C-TKI-International", "C-CP", "C-RO", "C-CPTI", "C-Integer-Detunata-RENT", "C-TKI-Other"}, "Attribute.1", "Value.1"),
#"Filtered Rows" = Table.SelectRows(#"Unpivoted Only Selected Columns", each true),
#"Changed Type3" = Table.TransformColumnTypes(#"Filtered Rows",{{"Value", type number}}),
#"Renamed Columns" = Table.RenameColumns(#"Changed Type3",{{"Attribute.1", "Client intern"}, {"Value.1", "Pecentage"}}),
#"Changed Type2" = Table.TransformColumnTypes(#"Renamed Columns",{{"Pecentage", type number}, {"Department ID", Int64.Type}, {"Status ID", Int64.Type}, {"Entity ID", Int64.Type}, {"Start Date", type date}})
in
#"Changed Type2"

 

Then I republished the report with another name and I got the same error for query No 1 mentioned above, again (you can see it again below)

It has 2 columns: a text column and the ID column (int).

 

let
Source = Table.Combine({PBI_WagesCat_appended, PBIDIm_CostPersonCat_new}),
#"Filtered Rows" = Table.SelectRows(Source, each ([Cont] <> null))
in
#"Filtered Rows"

 

I hope that Microsoft will fix this issue as soon as possible.

 

 

 

Hi @adriansuteu , I was experiencing the same issue as you and I was able to fix it by saving my Excel files as .xlsx files.  Previously my Excel sources were saved as .xls and by making this change I am now able to refresh on the desktop as well as the service.  You mentioned in your first post that your sources were Excel files and so maybe this is worth a try?

@keithtran12  thank you very much for your suggestion.

 

Our files are already saved in .xlsx format. It must be something else.

 

Thank you,

Adrian Suteu

I have no appending or combining but have the same issue (

Trying to manage with privacy settings

venal
Memorable Member
Memorable Member

@adriansuteu , @Jmenas 

Can you please follow the below steps and try to re-pro the issue.

1. Open the PBIX file in Power BI Desktop

2. File >> Options & Settings >> Clear Cache (Data , Q & A Cache Management).

3. Home >> Edit Queries >> Edit Queries >> Refresh Preview >> Refresh All >> Close & Apply.

4. Home >> Refresh >> Check the data in all visuals across the page levels.

5. File >> Save the PBIX File >> Publish.

Note:- Always use latest version of the on-premises data gateway. Use same privacy level in Desktop and Service.

 

If the issue is persists, please share the error message to investigate.

 

If you have any queries, please let us know.

 

If this post helps, then please consider Accept it as the solution to help the other members find it more
If this post was helpful may I ask you to mark it as solution and click on thumb symbol?

 

BR,

Venal.

Hello @venal 

 

I have followed your steps. Refresh worked fine, every visual shows the complete data.

 

I still get the same error.

 

I have used the same report, with the same table - PBI_Wages, from the same source type: Web (OneDrive Excel file) and query steps before and it worked fine. But this happend a while ago. PBI Service Refresh broke because other tables' structure changed. The report was not used a while (around 6 months). I downloaded the report, I changed the Data Source location (not type, just location from one sharepoint file to another - basically the same file copied in another place!) and made the required changes to make the other queries work in PBI Desktop - last version - the one with the fancy new ribbon.

 

This is the error:

There was an error when processing the data in the dataset.

Please try again later or contact support. If you contact support, please provide these details.

  • Data source error{"error":{"code":"ModelRefresh_ShortMessage_ProcessingError","pbi.error":{"code":"ModelRefresh_ShortMessage_ProcessingError","parameters":{},"details":[{"code":"Message","detail":{"type":1,"value":"Information is needed in order to combine data"}}],"exceptionCulprit":1}}} Table: PBI_Wages.
  • Cluster URIWABI-US-NORTH-CENTRAL-redirect.analysis.windows.net
  • Activity IDff02f260-104c-4e4b-b78a-54bf9f94f4d1
  • Request IDca2cf925-4e5a-eb61-02a6-23952f5c3834
  • Time2020-03-16 20:04:08Z

I was able to resolve this error using the following steps:

  • Open .pbix report in Power BI Desktop
  • File - Options & Settings - Data Source Settings --> Clear All Permissions
  • [not sure if this does anything] File - Options and Settings - Option --> Clear Cache in "Date Cache Management" and "Q&A Cache Options"
  • Home - Refresh --> keep track of how you log into each data source. In my case it was 3 sources, all Organizational privacy levels
  • Save and Publish the report
  • Go to data source in the PBI service, and re-login to each of the data sources under Data Source Credentials --> make sure you are using the same privacy level as desktop app, in my case it was all Organizational

Btw, this started with the latest version of Power BI Desktop so there is definitely a bug that resets privacy levels.

Anonymous
Not applicable

Thanks!! 👍 It's working for me after set the same privacy level as the desktop app.

Hi @sxt173

 

I followed your steps but I get the same error in PBI Service after republishing the report.


Thank you for the suggestion.

 

v-lili6-msft
Community Support
Community Support

hi  @adriansuteu 

Even though all the settings were correct in the destkop.  you also need reset the permsions on the power bi cloud (service) side by clicking edit credentials and setting he privacy settings and entering the password. 

 

Regards,

Lin

Community Support Team _ Lin
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Is there any update on this problem as i have followed all steps listed above with the same result of errors on refresh

Hello.

 

Thank you for your answer. Privacy was set on Organizational in Power BI Server from the beggining but I did the following thing:

I went to PBI Server and I clicked on "Edit Credentials" for every data source in the list, made sure it is set on Organizational and then click on Sign In and login again with my credentials.

I still get the following error:

 

Something went wrong
There was an error when processing the data in the dataset.
Please try again later or contact support. If you contact support, please provide these details.
Data source error: {"error":{"code":"ModelRefresh_ShortMessage_ProcessingError","pbi.error":{"code":"ModelRefresh_ShortMessage_ProcessingError","parameters":{},"details":[{"code":"Message","detail":{"type":1,"value":"Information is needed in order to combine data"}}],"exceptionCulprit":1}}} Table: PBI_Wages.
Cluster URI: WABI-US-NORTH-CENTRAL-redirect.analysis.windows.net
Activity ID: 2b5cd332-4393-4cee-96fb-e09826873874
Request ID: 3ae4c162-5dbf-afaf-e812-70eecd86e9bd
Time: 2020-03-13 08:14:51Z

Hi @v-lili6-msft 

 

I have tried many different things including the suggestion to clear cache and re-do the connection above and made the Privacy Levels in sync (Organizational)

 

I am connecting with Oracle Automonus database (cloud) in Power BI desktop. 

All working perfectly on the PBI desktop. I followed the instruction here exactly. 

 

Here is the error

 

Last refresh failed: 3/13/2024, 3:56:59 PM
There was an error when processing the data in the dataset

Data source error: {"error":{"code":"DM_GWPipeline_Gateway_MashupDataAccessError","pbi.error":{"code":"DM_GWPipeline_Gateway_MashupDataAccessError","parameters":{},"details":[{"code":"DM_ErrorDetailNameCode_UnderlyingErrorCode","detail":{"type":1,"value":"-2147467259"}},{"code":"DM_ErrorDetailNameCode_UnderlyingErrorMessage","detail":{"type":1,"value":"Oracle: ORA-12154: TNS:could not resolve the connect identifier specified"}},{"code":"DM_ErrorDetailNameCode_UnderlyingHResult","detail":{"type":1,"value":"-2147467259"}},{"code":"Microsoft.Data.Mashup.ValueError.DataSourceKind","detail":{"type":1,"value":"Oracle"}},{"code":"Microsoft.Data.Mashup.ValueError.DataSourcePath","detail":{"type":1,"value":"cqn2xyu823y3iwi9_high"}},{"code":"Microsoft.Data.Mashup.ValueError.ErrorCode","detail":{"type":1,"value":"-2147467259"}},{"code":"Microsoft.Data.Mashup.ValueError.Message","detail":{"type":1,"value":"ORA-12154: TNS:could not resolve the connect identifier specified"}},{"code":"Microsoft.Data.Mashup.ValueError.Reason","detail":{"type":1,"value":"DataSource.Error"}}],"exceptionCulprit":1}}} Table: CUSTOMER.
Cluster URI: WABI-AUSTRALIA-SOUTHEAST-redirect.analysis.windows.net

Hi @adriansuteu,
I am having the same error. For the report refresh was working fine until this Friday. After I added a new data source, I keep getting this message. @v-lili6-msft do you know if there is anything in the March update that might have affected the data privacy settings with the reports? 

Best,

Jorge

Helpful resources

Announcements
July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

July Newsletter

Fabric Community Update - July 2024

Find out what's new and trending in the Fabric Community.