Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

The ultimate Microsoft Fabric, Power BI, Azure AI & SQL learning event! Join us in Las Vegas from March 26-28, 2024. Use code MSCUST for a $100 discount. Register Now

Reply
Majkel
Helper I
Helper I

How to test RLS for all reports that share single dataset after service's look update?

Hi All,

 

Do we know how we could test RLS in Power BI Service for multiple reports that shares the same dataset? In the past it was possible by expanding reports in a given dataset, but after current look 'improvement' this feature is not possible anymore. 

 

@Sumanth_23 described the previous solution in the orignal post: https://community.powerbi.com/t5/Service/How-to-test-RLS-for-all-reports-that-share-a-single-dataset...

 

Majkel_2-1661501712073.png

 

But it seems we cannot be using this solution anymore, as we cannot expand the workspace view ;/ 

 

Majkel_1-1661501474818.png

 

Thanks in advance for your help

 

1 ACCEPTED SOLUTION
v-easonf-msft
Community Support
Community Support

Hi, @Majkel 

From my tests, I found that it doesn't work in "My Workspace".

You need to test it a new workspace. In the RLS role preview mode, I can normally switch between different reports corresponding to the same dataset in the same workspace.

 

veasonfmsft_1-1661828308490.png

 

veasonfmsft_0-1661828245304.png

Best Regards,
Community Support Team _ Eason

 

View solution in original post

5 REPLIES 5
v-easonf-msft
Community Support
Community Support

Hi, @Majkel 

From my tests, I found that it doesn't work in "My Workspace".

You need to test it a new workspace. In the RLS role preview mode, I can normally switch between different reports corresponding to the same dataset in the same workspace.

 

veasonfmsft_1-1661828308490.png

 

veasonfmsft_0-1661828245304.png

Best Regards,
Community Support Team _ Eason

 

I have been using this method, but the new navigation pane update seems to have broken this. I can't switch between reports in the nav pane. Am I missing something?

Hi @mbrewing 

 

I've leart that MS Team is currently working on fixing this bug, but there is a quick fix:

 

Add "?tridentStageTwo=0" to your URL , so try for example https://app.powerbi.com/home?tridentStageTwo=0 

 

It works for me!

It works! Thank you!

Majkel
Helper I
Helper I

Up

Helpful resources

Announcements
Fabric Community Conference

Microsoft Fabric Community Conference

Join us at our first-ever Microsoft Fabric Community Conference, March 26-28, 2024 in Las Vegas with 100+ sessions by community experts and Microsoft engineering.

February 2024 Update Carousel

Power BI Monthly Update - February 2024

Check out the February 2024 Power BI update to learn about new features.

Fabric Career Hub

Microsoft Fabric Career Hub

Explore career paths and learn resources in Fabric.

Fabric Partner Community

Microsoft Fabric Partner Community

Engage with the Fabric engineering team, hear of product updates, business opportunities, and resources in the Fabric Partner Community.

Top Solution Authors
Top Kudoed Authors