Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Earn a 50% discount on the DP-600 certification exam by completing the Fabric 30 Days to Learn It challenge.

Reply
Majkel
Helper I
Helper I

How to test RLS for all reports that share single dataset after service's look update?

Hi All,

 

Do we know how we could test RLS in Power BI Service for multiple reports that shares the same dataset? In the past it was possible by expanding reports in a given dataset, but after current look 'improvement' this feature is not possible anymore. 

 

@Sumanth_23 described the previous solution in the orignal post: https://community.powerbi.com/t5/Service/How-to-test-RLS-for-all-reports-that-share-a-single-dataset...

 

Majkel_2-1661501712073.png

 

But it seems we cannot be using this solution anymore, as we cannot expand the workspace view ;/ 

 

Majkel_1-1661501474818.png

 

Thanks in advance for your help

 

1 ACCEPTED SOLUTION
v-easonf-msft
Community Support
Community Support

Hi, @Majkel 

From my tests, I found that it doesn't work in "My Workspace".

You need to test it a new workspace. In the RLS role preview mode, I can normally switch between different reports corresponding to the same dataset in the same workspace.

 

veasonfmsft_1-1661828308490.png

 

veasonfmsft_0-1661828245304.png

Best Regards,
Community Support Team _ Eason

 

View solution in original post

5 REPLIES 5
v-easonf-msft
Community Support
Community Support

Hi, @Majkel 

From my tests, I found that it doesn't work in "My Workspace".

You need to test it a new workspace. In the RLS role preview mode, I can normally switch between different reports corresponding to the same dataset in the same workspace.

 

veasonfmsft_1-1661828308490.png

 

veasonfmsft_0-1661828245304.png

Best Regards,
Community Support Team _ Eason

 

I have been using this method, but the new navigation pane update seems to have broken this. I can't switch between reports in the nav pane. Am I missing something?

Hi @mbrewing 

 

I've leart that MS Team is currently working on fixing this bug, but there is a quick fix:

 

Add "?tridentStageTwo=0" to your URL , so try for example https://app.powerbi.com/home?tridentStageTwo=0 

 

It works for me!

It works! Thank you!

Majkel
Helper I
Helper I

Up

Helpful resources

Announcements
RTI Forums Carousel3

New forum boards available in Real-Time Intelligence.

Ask questions in Eventhouse and KQL, Eventstream, and Reflex.

MayPowerBICarousel

Fabric Monthly Update - May 2024

Check out the May 2024 Fabric update to learn about new features.

LearnSurvey

Fabric certifications survey

Certification feedback opportunity for the community.

Top Solution Authors