Skip to main content
Showing results for 
Search instead for 
Did you mean: 

The ultimate Microsoft Fabric, Power BI, Azure AI & SQL learning event! Join us in Las Vegas from March 26-28, 2024. Use code MSCUST for a $100 discount. Register Now

Not applicable

Hierarchy slicer erroring after today's update

Hi all,


I have several reports that use the hierarchy slicer, which were all working fine for months until today. When you try to filter at any node of the hierarchy slicer, all other visuals error out with the "!" cannot display data.


I've found that this only impacts my reports in the Power BI service and Power BI embedded, but the desktop version of the report filters without errors.


I also noticed that if change the Empty Leaf setting to On (default), the filtering works again! However, I really like the ability to turn off the empty leafs as it is a better user experience. Has anyone else had issues after today's update to PBI service/Desktop? If you have reports with the attribute slicer, please test and let me know!


 @jppp - If you have any updates, please let me know as well. I really love the custom visual and use it for many clients. I'm also curious if there is support to pass through the of the hierarchy slicer (lowest chosen level) when using the new Drillthrough feature. It doesn't seem to pass the correct context to the drillthrough page.





Hi @Mardin,


The current version should not be giving blank visuals and can be forced to be used by manual clearing the browser cache.




View solution in original post

Frequent Visitor

My hierarchy Slicer went blank today in IE11. It was working fine yesterday. I tried clearing my cache and it still doesn't work.


It's showing up in Chrome and Power BI desktop. Can anyone help? All users in my company are using IE.

Hi @kwu ,


There is an issue with the HierarchySlicer and Internet Explorer and a fix is comming.

Please use another browser (Chrome, Firefox or Edge) as a workaround.


Thanks, Jan Pieter

Frequent Visitor

Hi @jppp ,


Same problem happens again today. The hierarchy slicer went blank in IE11 again. Any idea what happened? Will a fix be implemented soon? unfortunately, users in our company are using IE11 as the official browser here. Thanks.



I can also confirm on IE11 the Hierarchy slicer is blank again.  Thought this was fixed not that long ago.  Works fine on Chrome.

Accidentally a wrong version of the HierarchySlicer has been released by Microsoft which is causing this behavior, but now the correct working version is available again.



Frequent Visitor

Hi @jppp ,


The hierarchy slicer is back to normal now. Thanks.

Advocate II
Advocate II

We can't click any fields in the hierarchy slicer whatsoever-- tried Chrome, IE, Edge. The only time it works is if we select a field in a hierarchy slicer already expanded.



Advocate I
Advocate I

Same issue here, works in Chrome but not in Internet Explorer. When I edit the report in IE11, the Hierarchy Slicer is even gone in the list with Visualizations. 



Version: 11.0.9600.18920

Update versions: 11.0.51 (KB4074736)


Please fix this asap, this sort of bugs puts the reputation of Power BI on the line in my organization...

Kind regards,


Frequent Visitor

I also experience error with the Hierarchy Slicer in all our dashboards. It works fine in Desktop version, but not when you publish to Poweer BI services. I have tried to re-upload my dashboards and create a new hierarchy slicer, but nothing works. 😞

Not applicable

I'll piggyback here.  I'm also getting issues with this Slicer, but with how it draws.  It appears to draw all of the labels Right Justified.  Example below.
EDIT: Clarify this is Microsoft Edge


Correct Display / Current Display


Contents of Hierarchy slicer is blank in Internet Explorer but works fine in Google Chrome.

Works fine in Power BI Desktop, but not in published reports which are accessed via the Power BI on Premises Data Gateway

There is an issue with IE11 causing the visual to be blank and there is a fix on its way.


Also in this new version there is a fix of the levels being right aligned.


@Anonymous: which version of Edge are you seeing this behavior?

I do not see this behavior in the latest version (17.17134)


@Anonymous: The internal selection method has changed with this version. Can you try resetting the current seelction of the slicer and try again? And if it is still not working, can you share an example with me?


Not applicable

@jppp I've tried deleting and re-adding the visual, and re-setting/clearing all selections. It doesn't matter which node I choose, it will always cause all other visuals to error out with "Cannoy display visual."


It works 100% as expected in the Desktop. It only works in when I have the Empty Leaf Setting to ON, which will show all the Blanks at each level, but allows the filtering to work correctly. I also noticed the carrots/arrows are missing from certain root nodes. For example, the category with a 7 should have  > expander option pictured below. This is from Chrome.


Let me know what other details you need.



hierarchy error.PNG

@jpppToday the problem occurred again. For the option of not showing empty values, the filter corrupts the entire report. This problem occurs both in (IE11, Chrome) and Desktop.


Please check this problem 🙂 

Not applicable


I am facing similar issue.Hierarchy slicer is not working today on desktop and service both.

It throws error on selection.


It was working fine earlier.

Kindly help.



@jpppToday the problem occurred again. For the option of not showing empty values, the filter corrupts the entire report. This problem occurs both in (IE11, Chrome) and Desktop.


Please check this problem 🙂 

@Anonymousis it possible to share a desktop file with me as I cannot reproduce this behavior?

Not applicable

@jppp - I sent you a message with a link to download the PBIX. Let me know if you have any issues accessing it.


@willnic - What are the settings of your report? When you click any node in the hierarchy slicer does it cause your visuals to error as well?


I only have the issue in and Power BI embedded. My report is a direct query report, but I do get errors on the imported version as well.

@Anonymous I am live connected to a tabular model on If I don't have a hierarchy in the slicer (i.e. just one level) I can't click the slicer box whatsoever. If I do have a hieararchy in the slicer, the visuals throw an error when I click the top hierarchy, but visuals do work if I click the 2nd level hierarchy (more detailed hieararchy).

Not applicable

Interesting. Mine errors out the visuals no matter which node I click (in The Desktop version works without issues.


We will have 6+ hierarchy levels, so it would be very cumbersome to add 6 drop down filters for each level of the hierarchy. Then we have a second hierarchy with 6+ levels as well. 


Helpful resources

Fabric Community Conference

Microsoft Fabric Community Conference

Join us at our first-ever Microsoft Fabric Community Conference, March 26-28, 2024 in Las Vegas with 100+ sessions by community experts and Microsoft engineering.

February 2024 Update Carousel

Power BI Monthly Update - February 2024

Check out the February 2024 Power BI update to learn about new features.

Fabric Career Hub

Microsoft Fabric Career Hub

Explore career paths and learn resources in Fabric.

Fabric Partner Community

Microsoft Fabric Partner Community

Engage with the Fabric engineering team, hear of product updates, business opportunities, and resources in the Fabric Partner Community.

Top Solution Authors
Top Kudoed Authors