Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Earn a 50% discount on the DP-600 certification exam by completing the Fabric 30 Days to Learn It challenge.

Reply
mnahmany
Frequent Visitor

HIDE "FILTERS AND SLICERS AFFECTING THIS VISUAL"

Our users get this pop-up window every time they hover over the filter icon, and they don't want or need to see it at all (for any visual), and it's annoying to them.

How can we hide it for all the organization reports?

 

Thank you!

1 ACCEPTED SOLUTION
Pragati11
Super User
Super User

HI @mnahmany ,

 

Go to Power BI Desktop --> Open your report --> Disable "Visual Header" option for all of your visuals.

Under this option, you have multiple formatting options on what all you want to get displayed and what all not.

 

In order to see the effect of this change, Save your report and publish to Power BI Service. Then  you will see the chnages.

 

Any chnage you make related to "Visual Header" settings in Power BI Desktop, can only be seen in Power BI Service after publishing your report.

 

Refer the following link for additional details:

https://www.wiseowl.co.uk/blog/s2611/visual-headers.htm

 

Thanks,

Pragati

Best Regards,

Pragati Jain


MVP logo


LinkedIn | Twitter | Blog YouTube 

Did I answer your question? Mark my post as a solution! This will help others on the forum!

Appreciate your Kudos!!

Proud to be a Super User!!

View solution in original post

8 REPLIES 8
KfireC
Frequent Visitor

Not sure what version you are running. I am running Version: 2.116.966.0, and it is annoying to see "Filters on Visual" etc. icons on the same line as the visual header. 

By choosing, File--> Options and settings --> Options --> In the CURRENT FILE menu, --> Report Settings under Visual Options, I removed the check mark for "Use the modern visual header with updated styling options." and saved the file. When the file is reopened the icons no longer appear on the header bar.

Pragati11
Super User
Super User

HI @mnahmany ,

 

Go to Power BI Desktop --> Open your report --> Disable "Visual Header" option for all of your visuals.

Under this option, you have multiple formatting options on what all you want to get displayed and what all not.

 

In order to see the effect of this change, Save your report and publish to Power BI Service. Then  you will see the chnages.

 

Any chnage you make related to "Visual Header" settings in Power BI Desktop, can only be seen in Power BI Service after publishing your report.

 

Refer the following link for additional details:

https://www.wiseowl.co.uk/blog/s2611/visual-headers.htm

 

Thanks,

Pragati

Best Regards,

Pragati Jain


MVP logo


LinkedIn | Twitter | Blog YouTube 

Did I answer your question? Mark my post as a solution! This will help others on the forum!

Appreciate your Kudos!!

Proud to be a Super User!!

Hi, I have Power BI Version: 2.103.881.0 and this is not working for me. I want to embed a report without the filters, should be something prety easy to do.

santiagoluquez_0-1649432170173.png

 

When I hide the Visual Header the elipsis that enables export to Excel is hidden as well, and the users are not able to export data.

Is there a default option to enable only the Export feature?

The filter pop-ups are annoying to ourusers.

 

Thanks.

Hi @mnahmany ,

 

If you don't want everything to be hidden then under switch on Visual Header option. Under this option you have multiple settings as well.

Apart from "More Options" icon, disable everything under this. In this way you will see 3 dots icon only on your visual:

Pragati11_0-1597760744828.png

 

Make sure you test this chnage in Power BI service, as it will not be reflected in Power BI Desktop.

 

Thanks,

Pragati

Best Regards,

Pragati Jain


MVP logo


LinkedIn | Twitter | Blog YouTube 

Did I answer your question? Mark my post as a solution! This will help others on the forum!

Appreciate your Kudos!!

Proud to be a Super User!!

Thank you Pragati11 

 

To make sure I understand: if I have 100 visuals in a report, I have to click 12 toggle buttons for each and every visual (leaving only the "more options" active)? so 1200 clicks altogether...

 

And there's no way to disable all the toggles and then re-enable only the ones that we need?

 

Thanks again!

Anand24
Super User
Super User

Hi @mnahmany ,

 

You need to disable "Visual Header" of each and every visual you have.

visual_header.PNG

 

Give a thumbs up if this post helped you in any way and mark this post as solution if it solved your query !!!

I disabled the header but when I hover over the filter icon I still get the popup.

Helpful resources

Announcements
LearnSurvey

Fabric certifications survey

Certification feedback opportunity for the community.

PBI_APRIL_CAROUSEL1

Power BI Monthly Update - April 2024

Check out the April 2024 Power BI update to learn about new features.

April Fabric Community Update

Fabric Community Update - April 2024

Find out what's new and trending in the Fabric Community.

Top Solution Authors
Top Kudoed Authors