Forum Discussion
Gateway & Custom connector: 404 not found
Hello everyone,
I'm working on a tableau migration and we are trying to reproduce a custom connector from tableau into power BI
The connector has been developed and everything is working fine with it (on our local machine).
According to Microsoft documentation, we performed some testconnections and everything was working
The hell started once we decided to used this connector with our data gateway to be able to schedule some refrehses for our reports...
my .mez files is well deployed on my server
In Power BI Services, I go in manage gateway, there I'm able to select the gateway that I deployed on my server; but when I try to create the connection, it is returning the following error message:
Unable to create connection for the following reason:
Unable to connect the data source. Either the data source is inaccessible, a connection time out occured or the data source credentials are invalid. Please verify the data source configuration and contact a data source administrator to troubleshoot this issue.
So after some advices, we installed power BI desktop on our server (on which the gateway is installed) and try to use it but we got some erorr message, the first one mentionned that the gateway was unable to reach the site via the API, after the opening of the flow into server, we got a new error message, and I'm stuck with this one :
Datasource.Error: Web.Contents failed to get contents from 'https://mywebsite.com/api/dataset/queries/async/' (404): not found
So on my personal computer, it is working perfectly
Any idea of how could I tackle this issue?
Many thanks for your help 🙂
2 Replies
- lbendlin
Super User
after the opening of the flow into serverdid you modify the firewall settings? Is there a proxy blocking the traffic, or a corporate network firewall?
- AnonymousNot applicable
Hello lbendlin
Once again, thank you for your help
Finally, the user just made a mistake when he typed the api url...
But I'm still facing to an issueSo to summarize, from the server (on which the gateway is deployed), we are able to use the custom connector in Power BI desktop without any issue
So I tried to use my custom connector to refresh my report, and it is returning the following issue:Data source error: {"error":{"code":"DM_GWPipeline_Gateway_MashupDataAccessError","pbi.error":{"code":"DM_GWPipeline_Gateway_MashupDataAccessError","parameters":{},"details":[{"code":"DM_ErrorDetailNameCode_UnderlyingErrorCode","detail":{"type":1,"value":"-2147467259"}},{"code":"DM_ErrorDetailNameCode_UnderlyingErrorMessage","detail":{"type":1,"value":"We cannot convert the value null to type Logical."}},{"code":"DM_ErrorDetailNameCode_UnderlyingHResult","detail":{"type":1,"value":"-2147467259"}},{"code":"Microsoft.Data.Mashup.ValueError.Reason","detail":{"type":1,"value":"Expression.Error"}}],"exceptionCulprit":1}}} Table: Query1. The only setting required by the data gateway is the api url, and that is (I had to select skip test connection during the gateway configuration) just to check if I got a message with more details
Any idea on which side should I start to invest?