Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Earn a 50% discount on the DP-600 certification exam by completing the Fabric 30 Days to Learn It challenge.

Reply
jismith
Advocate I
Advocate I

Filter Issue: "Select All" not holding selections when using filter search bar

Hi,

 

I want end users to be able to EXCLUDE one or more products from a (very large) number of products.  The only way I could make this work was to use a Basic Filter and follow the steps:

 

  1. Select All -- all products are selected (check mark ON)
  2. Search product -- shorter list of relevant products is visible and selected (check mark ON)
  3. Deselect product -- filter returns "IS NOT [product name]" result

This still works in my desktop version but on the site the selection is not holding when the search bar is used, you can only SELECT the product rather than DESELECT.

 

Is this a deliberate change in functionality or a temporary glitch?  Is there an alternative way to create an exclusion filter?  (Please note that I am using a tabular cube and cannot edit my data model.)

 

Thanks,

12 REPLIES 12
Anonymous
Not applicable

I am having the same unexpected behavior in service vs desktop.  I recreated a new .pbix with one calendar table and published to Service to reproduce.  

 

Expected behavior: Select All > type in "Nov" > "Nov" is removed and rest of data remains

 

Service:

 

Step1.PNGStep2.PNGStep3.PNG

 

 

 

 

 

 

 

 

 

 

 

 

 

Desktop:

 

Desktop1.PNGDesktop2.PNGDesktop3.PNG

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Desktop works as expected.  Has anyone been able to resolve?

@Anonymous 

 

I believe the above issue was with slicer visual.

 

You are using filter panel.You should select "Advanced filtering" in the dropdown and choose "is not" and key in the value. Do remember to hit "Apply filter" at the bottom.

image.png

 

@jismith 

 

Were you also looking at this in Filter panel instead of filter visual?

 

Yellow highlighted is Filters Panel and red circled in Slicer/Filter visual

image.png

 

If this helps, mark it as a solution.

Kudos are nice too

Connect on LinkedIn
VasTg
Memorable Member
Memorable Member

@Anonymous 

 

I was wrong.. Infact it seems to be a bug in Filter Panel. Though we could use Advanced filtering and is not option, it doesn't give search facility.

 

@v-lid-msft 

 

It works in slicer visual but the behaviour between desktop and service is different in Filter panel as @Anonymous  mentioned.

Could you report this?

 

 

Connect on LinkedIn

Hi @VasTg ,

 

Thank you for your test, We have the same result as yours and @jismith 's, We will report this behaviour of Filter Panel, We think the slicer visual could be a temp workaround.


We will update here if we got any new.


Best regards,

 

 

 

Community Support Team _ Dong Li
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Thanks all.

Hi @jismith ,

 

Based on my test, it seems work on Power BI Service currently, could you please try to test it  to see if it works on your side?

 

11.jpg


Best regards,

Community Support Team _ Dong Li
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
VasTg
Memorable Member
Memorable Member

@jismith 

 

It should work.

1. Sample Slicer

image.png

2. "Select all"

image.png

3. Search and uncheck

Search for RetailSearch for Retail

 

5 Final

image.png

 

If this helps, mark it as a solution

Kudos are nice too

 

 

Connect on LinkedIn

Yes, that is how it should work (and does work in the desktop) but in my published apps it is not working.  Are you suggesting this is a temporary glitch, @VasTg  ?

VasTg
Memorable Member
Memorable Member

@jismith 

Is it in service(Reports/Dashboards) or Apps? Try these steps

 

1. Reset to default.

2.Try the report in new incognitive window in a new browser

3. Update the app it is published to app

4. Restart your capacity.

 

Let us know 

 

If this helps, mark it as a solution

Kudos are nice too

Connect on LinkedIn

@VasTg thanks.  Unfortunately none of those things fixed it.

Hi @jismith ,

 

Sorry for that, we cannot reproduce this issue on Import Mode Or Live Connection. We have the same result in Desktop and Service. Are you using the Live Connection Mode?

 

7.jpg8.jpg


Best regards,

 

Community Support Team _ Dong Li
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
VasTg
Memorable Member
Memorable Member

@jismith 

 

Could you post a screenshot of the filter? Are you using any custom slicer?

 

Hope you are not clicking on the "Clear selection" icon mistakenly..

Connect on LinkedIn

Helpful resources

Announcements
RTI Forums Carousel3

New forum boards available in Real-Time Intelligence.

Ask questions in Eventhouse and KQL, Eventstream, and Reflex.

LearnSurvey

Fabric certifications survey

Certification feedback opportunity for the community.

Top Solution Authors
Top Kudoed Authors