Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

The ultimate Microsoft Fabric, Power BI, Azure AI & SQL learning event! Join us in Las Vegas from March 26-28, 2024. Use code MSCUST for a $100 discount. Register Now

Reply
WendyDUFE
Helper III
Helper III

Export data wierd behavior when deploy report / dashboard with sensitivity label via Pipeline

Hi All,

 

I am using pipeline to deploy my dataset and reports cross different workspaces (basically they are different environment: Dev - > Test - > Production).

 

When I created the pipeline, the datasets and reports are configured with Sensitivity label in dev environment.

 

According to the official document, it is mentioned that the sensitivity label will be copied to target since this is the new item deployed. It behaves properly by now. The target workspace (Test) dataset and reports are also with the sensitivity label configured.

 

---- Wierd behavior 1 -------

However, in the test environment, when I tried to export the data , it pop up error message saying "The sensitivy label applied to this file currently can't be retreieved from the data protection service, preventing the export. Content your Power BI admin for help". (export the current view, summarized data, underlying data all have this issue)

 

I checked back in the dev workspace, it all works with no such kind of error.

Data export.pngSensitivity label error .pngall exports options are available, the export settings are correctall exports options are available, the export settings are correct

---- Wierd behavior 2 -------

Then I tested all my other pipelines. Found another weird behavior. One of the pipeline, in test workspace, it can export current view data and underlying data, but only when export the summarized data, it shows the error.

 

---- Wierd behavior 3 -------

Then I tried to remove the sensitivity label in the test workspace, and reassign the same sensitivy label to it. The issue will be resolved.

 

May I know if this is a pipeline VS sensitivity label scenaria constraint ? OR it is a bug ?

 

BTW, the users encounter the above issues are B2B (guest ) users - their access to the workspace is viewer. The other tenant users have no such issue.

This is the Information Protection current settings for my tenantThis is the Information Protection current settings for my tenant

2 REPLIES 2
v-yanjiang-msft
Community Support
Community Support

Hi @WendyDUFE ,

Here are some related article and similar threads:

Deployment pipelines - Power BI | Microsoft Docs

Digging into Power BI Deployment Pipelines

Power BI Sensitivity label and Power BI Deployment... - Microsoft Power BI Community

Hope it helps!

 

Best Regards,
Community Support Team _ kalyj

If this post helps, then please considerAccept it as the solution to help the other members find it more quickly.

WendyDUFE
Helper III
Helper III

any one has any clue ? any idea ?

Helpful resources

Announcements
Fabric Community Conference

Microsoft Fabric Community Conference

Join us at our first-ever Microsoft Fabric Community Conference, March 26-28, 2024 in Las Vegas with 100+ sessions by community experts and Microsoft engineering.

February 2024 Update Carousel

Power BI Monthly Update - February 2024

Check out the February 2024 Power BI update to learn about new features.

Fabric Career Hub

Microsoft Fabric Career Hub

Explore career paths and learn resources in Fabric.

Fabric Partner Community

Microsoft Fabric Partner Community

Engage with the Fabric engineering team, hear of product updates, business opportunities, and resources in the Fabric Partner Community.

Top Solution Authors
Top Kudoed Authors