Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Earn a 50% discount on the DP-600 certification exam by completing the Fabric 30 Days to Learn It challenge.

Frequent Visitor

Error when trying to use copilot with PowerBI

We're looking to using Copilot with our Fabric/PowerBI service.
I'm getting the following error message when I try to access Copilot from with the PowerBI report window;
"To use Copilot, save your report to a workspace with the right capacity and permissions"
I can access Copilot just fine from a notebook in the same capacity/workspace.

Any suggestions as to how I can remedy this issue?

Extra info
The capacity is definitely set to F64.
I've paused and resumed the capacity.
I've created a new Workspace (of which I am an admin for)
I've ensured the workspace is using our paid capacity.
I've created and saved a new report in that workspace (linked to a Lakehouse I created and am owner of)

New Member

I am facing a similar issue, I am able to make use of Copilot with other exepriences, but only with Power BI I keep getting the message "To use Copilot, save your report to a workspace with the right capacity and permissions". Were you able to resolve the issue?

Super User
Super User

I've paused and resumed the capacity.

How did you do that?  Curious as this is not possible any more with P SKUs.

We have a paid-as-you-go F-capacity that I can administer.  Along with the ability to scale from F1 up to F-huge, there is an option in the overview page to Pause, which then morphs to Resume if the capacity is paused.

Helpful resources


Fabric certifications survey

Certification feedback opportunity for the community.


Power BI Monthly Update - April 2024

Check out the April 2024 Power BI update to learn about new features.

April Fabric Community Update

Fabric Community Update - April 2024

Find out what's new and trending in the Fabric Community.

Top Solution Authors
Top Kudoed Authors