Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
guillermoSoto
Frequent Visitor

Error trying to set up a custom connector in a gateway

We are developing a custom connector for Power BI Desktop, this connector retrieves data from an API where you need to authenticate, we use OAuth as an authentication method.

 

Everything works well with Power BI Desktop, and we want to use this connector on Power BI service, we were told that in order to do this we needed an on-premises data gateway, we tried both types of gateways (standard and personal), but we are facing some issues.

 

For the standard gateway, whenever we want to create a new connection, we set everything but when we try to connect, we get the following error: 'Unable to create connection for the following reason: There was an error in the data gateway.'

 

Screenshot 2023-07-31 171811.png

We installed the latest version of the gateway, and the problem is still there. However, we made a test by changing the authentication method to Anonymous, and apparently it works that way, but, obviously, we are not able to connect to the API to retrieve the info we need. Any ideas?

 

For the personal gateway, when we want to set a scheduled refresh for a dataset that we published using Power BI Desktop, and the custom connector, we get the following warning:'Failed to test the connection to your data source. Please retry your credentials.'

 

MicrosoftTeams-image (4).png

If we click on the option ‘Edit credentials’, a browser window pops up, but we are not able to login because the page is blank. Any ideas? Are we missing something in the authentication or when we setup the gateway?

3 REPLIES 3
aj1973
Community Champion
Community Champion

Hi @guillermoSoto 

Try this

https://learn.microsoft.com/en-us/power-bi/connect-data/service-gateway-custom-connectors

Regards
Amine Jerbi

If I answered your question, please mark this thread as accepted
and you can follow me on
My Website, LinkedIn and Facebook

Hi @aj1973,

 

Thanks for the answer, we saw that the problem was on our side, and not in the configuration of the gateway.

 

Regards,

Guillermo.

Hello @guillermoSoto 

I'm facing a similar issue, was it something wrong into your connector code ?
For which kind of gateway did you fix this issue, personnal or standard ?


Helpful resources

Announcements
July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

July Newsletter

Fabric Community Update - July 2024

Find out what's new and trending in the Fabric Community.