Forum Discussion

Anonymous's avatar
Anonymous
Not applicable
2 years ago

Error trying to refresh report in PBI Service

Trying to avoid the need for a gateway, I moved my Excel file into a folder in SharePoint Online.  My account has access to the SPO site and is able to open and edit the Excel data source.  The Excel file is the only data source in this report and there are only a few thousand records (it is a test file to see if I can make this work).

I created the Power BI report in the Desktop and connected to the Excel file in SharePoint.  So far, so good.

I published the file into the Power BI Service; the report and its matching semantic model are in My Workspace.

PROBLEM:

When I click the refresh button in the report or on the semantic model in My Workspace, it fails; the error is below.  

I don't know what the issue about credentials is.  I am signed-in to the M365 account that has access to the SharePoint site and is the same account I am using in Power BI Service.

Anything you can tell me would be helpful.  Thank you.

 

 

 

4 Replies

  • On your semantic model's settings page observe the yellow triangle next to the sharepoint folder connector. Edit credentials (renew access token) to make that triangle go away.

  • Anonymous's avatar
    Anonymous
    Not applicable

    Hi Anonymous ,

     

    I’d like to acknowledge the valuable input provided by lbendlin . Their initial ideas were instrumental in guiding my approach. However, I noticed that further details were needed to fully understand the issue. 

     

    The Microsoft Entra ID OAuth token, used by many different data sources, expires in approximately one hour. Sometimes that token expires before the data has finished loading, since the Power BI service waits for up to two hours when loading data. In that situation, the data loading process can fail with a credentials error.

     

    Data sources that use Microsoft Entra ID OAuth include Microsoft Dynamics CRM Online, SharePoint Online (SPO), and others. If you’re connecting to such data sources, and get a credentials failure when loading data takes more than an hour, OAuth might be the reason.

     

    For refresh to work properly when connecting to an SPO data source by using Microsoft Entra ID OAuth, you must use the same account that you use to sign in to the Power BI service.

     

    More detailed information can be found in the documentation:

    Troubleshoot refresh scenarios - Power BI | Microsoft Learn

     

    If your Current Period does not refer to this, please clarify in a follow-up reply.

     

    Best Regards,

    Clara Gong

    If there is any post helps, then please consider Accept it as the solution  to help the other members find it more quickly.

    • Anonymous's avatar
      Anonymous
      Not applicable

      Hi v-kaiyue-msft,

      Thank you for the response.  I am signed-in to the same account for all these activities.

      In the semantic model, I went to the Settings screen and noticed that "Data source credentials" is greyed-out.

       

      It seems that--with the timings and expiractions and such that this action (refresh) is subjected to--perhaps a Gateway is still going to be required.  Would I be correct that a Gateway would solve these problems in that it would maintain a constant connection with the data source?

       

      (I think I have a lot more homework to do!)

      • lbendlin's avatar
        lbendlin
        Icon for Super User rankSuper User

        SharePoint Online does not require a gateway.  Your semantic model must contain other , on-premise data sources that do require a gateway.

         

        In Power BI Desktop check "Data Source Settings"