Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Earn a 50% discount on the DP-600 certification exam by completing the Fabric 30 Days to Learn It challenge.

Reply
Dog
Responsive Resident
Responsive Resident

Enterprise Gateway - Problem with refreshing reports and dashboards

Hi All, 

 

We have recently upgraded the on premise data gateway service. (yesterday afternoon)

since then I have had nothing but problems. 

newly published reports are not loading all items. 

existing reports not refreshing visual on filter changes (just sits with spinning circle in top left of visual) 

 

I have reinstalled the gateway - same. 

Server has been restarted also. 

 

the only error I can see in the gateway log is the following which I'm not sure where to look. 

the Service appears to be restarting every few minutes (noticed in event viewer - many start notifications but not many stops so I assume it's crashing. 

 

DM.EnterpriseGateway Error: 0 : 2017-07-04T14:04:49.5497560Z DM.EnterpriseGateway 04d3466c-b801-44aa-949a-f37eab07f9af 4d3a71d2-751b-4382-9558-9269a0b34e14 MGPS 1deea692-b431-479f-a1ae-2bdfc6af5205 34808F03 [DM.Pipeline.Common] Non-gateway exception encountered in activity scope: System.ArgumentNullException: Value cannot be null.
Parameter name: pUnk
at System.Runtime.InteropServices.Marshal.GetObjectForIUnknown(IntPtr pUnk)
at Microsoft.PowerBI.DataMovement.Pipeline.OleDbBase.IMultipleResultsExtensions.GetResult(IMultipleResults multipleResults)
at Microsoft.PowerBI.DataMovement.Pipeline.GatewayCore.Serialization.OleDbBinaryWriterSerializer.<GetRowsets>d__10.MoveNext()
at Microsoft.PowerBI.DataMovement.Pipeline.GatewayCore.Serialization.OleDbBinaryWriterSerializer.Serialize(OleDbBinaryPacketWriteStream oleDbPacketStream, Boolean isLast)
at Microsoft.PowerBI.DataMovement.Pipeline.GatewayCore.Serialization.OleDbBinaryWriterSerializer.Serialize(GatewaySerializationContext serializationContext, Int32 indexForFirstPacket, Boolean isLast)
at Microsoft.PowerBI.DataMovement.Pipeline.GatewayCore.Serialization.GatewaySerializer.<SerializeOleDbQueryResponseMultipleResults>d__18.MoveNext()
--- End of stack trace from previous location where exception was thrown ---

 

any one else having problems or do you have any ideas on where to start looking

 

Many Thanks

8 REPLIES 8
v-ljerr-msft
Employee
Employee

Hi @Dog,

 

I have tested it that the latest version of On-premises data gateway works all fine for me without these issues.

 

If you still cannot create a support ticket on Power BI Support page, could you try submitting a Service Request via the Office 365 Admin Portal to contact Power BI Support. Here is the article for your reference. Smiley Happy

 

Regards

Dog
Responsive Resident
Responsive Resident

Hi @v-ljerr-msft

 

would you mind letting me know what settings you have in the "Microsoft.PowerBI.DataMovement.Pipeline.GatewayCore.dll.config" file. 

 

these settings appear to be new in the upgrade and some of mine are empty. 

 

<setting name="ADUserNameReplacementProperty" serializeAs="String">
<value />
</setting>
<setting name="ADServerPath" serializeAs="String">
<value />
</setting>
<setting name="CustomASDataSource" serializeAs="String">
<value />
</setting>
<setting name="ADUserNameLookupProperty" serializeAs="String">
<value />
</setting>
<setting name="MashupExtensionEnabled" serializeAs="String">
<value>True</value>
</setting>
<setting name="MashupExtensionWhiteList" serializeAs="String">
<value>Impala</value>
</setting>
<setting name="MashupDQPoolContainerMaxCount" serializeAs="String">
<value>20</value>
</setting>
<setting name="MashupDQPoolContainerMaxWorkingSetInMB" serializeAs="String">
<value>64</value>
</setting>
<setting name="MashupDQPoolContainerTimeToLiveInMinute" serializeAs="String">
<value>60</value>
</setting>
<setting name="MashupDQPoolCacheTimeToLiveInMinute" serializeAs="String">
<value>15</value>
</setting>
<setting name="MashupDQPoolSessionTimeToLiveMinute" serializeAs="String">
<value>15</value>
</setting>
<setting name="MashupDQCommandTimeoutInSecond" serializeAs="String">
<value>225</value>
</setting>

 

 

Hi @Dog,

 

I just checked the settings, and it seems the same as yours. Smiley Happy

<setting name="ADUserNameReplacementProperty" serializeAs="String">
        <value />
      </setting>
      <setting name="ADServerPath" serializeAs="String">
        <value />
      </setting>
      <setting name="CustomASDataSource" serializeAs="String">
        <value />
      </setting>
      <setting name="ADUserNameLookupProperty" serializeAs="String">
        <value />
      </setting>
      <setting name="MashupExtensionEnabled" serializeAs="String">
        <value>True</value>
      </setting>
      <setting name="MashupExtensionWhiteList" serializeAs="String">
        <value>Impala</value>
      </setting>
      <setting name="MashupDQPoolContainerMaxCount" serializeAs="String">
        <value>20</value>
      </setting>
      <setting name="MashupDQPoolContainerMaxWorkingSetInMB" serializeAs="String">
        <value>64</value>
      </setting>
      <setting name="MashupDQPoolContainerTimeToLiveInMinute" serializeAs="String">
        <value>60</value>
      </setting>
      <setting name="MashupDQPoolCacheTimeToLiveInMinute" serializeAs="String">
        <value>15</value>
      </setting>
      <setting name="MashupDQPoolSessionTimeToLiveMinute" serializeAs="String">
        <value>15</value>
      </setting>
      <setting name="MashupDQCommandTimeoutInSecond" serializeAs="String">
        <value>225</value>
      </setting>

 

Regards

Dog
Responsive Resident
Responsive Resident

Thanks for that - at least it confirms it's not those then 🙂

 

I'll raise a service request as you mentioned earlier, 

 

Cheers

 

Dog

freek80
Frequent Visitor

Hi!

 

We experienced this issue also,

 

you can find the solution right here:

 

https://community.powerbi.com/t5/Desktop/Enterprise-Gateway-stops-and-start-multiple-times/m-p/20777...

 

 

Dog
Responsive Resident
Responsive Resident

Hi All, 

 

this is still an issue - I've tried submitting a support ticket but apparently "Error submitting request. Try again shortly." I've been trying since yesterday. 

 

 

We are also experiencing this issue and have gone through all of the recommended steps, and are now looking to the community.

 

Gateway is on Windows Server 2012

SQL Server is on Windows Server 2016

Connecting a Power BI report directly (Live Connection) to SSAS 2016 Multidimensional Cube

 

Is it a bug with the queries being produced for SSAS or perhaps a bug with the serialising of data back up to powerbi.com via the gateway?

We are also experiencing this issue.

 

Gateway is on Windows Server 2012

SQL is on Windows Server 2016

Connecting a Power BI dashboard directly (Live Connection) to SSAS 2016 Multidimensional Cube

 

Any movement on this issue? It's come at the worst time for us the day before the demonstration to the executives!

Helpful resources

Announcements
RTI Forums Carousel3

New forum boards available in Real-Time Intelligence.

Ask questions in Eventhouse and KQL, Eventstream, and Reflex.

MayPowerBICarousel

Power BI Monthly Update - May 2024

Check out the May 2024 Power BI update to learn about new features.

LearnSurvey

Fabric certifications survey

Certification feedback opportunity for the community.

Top Solution Authors