Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
pbiuser1222
New Member

Embedded Reports Not Loading in Chrome

Hello,

 

I have recently published various reports publicly to the web. I embedded the links in iframes and they are able to load fine on Firefox and Edge browsers. However, the reports do not load and throw errors when loaded on Chrome. Sometimes they are able to load on chrome, and sometimes they aren't. Also, the reports seem to load fine on chrome when I manually right click the iframe and select "reload frame". 

 

The error thrown in the console when a dashboard doesn't load is as follows: 

AI: StringValueTooLong message:"string value is too long. It has been truncated to 1024 characters." props:"{value:Error: Uncaught (in promise): TypeError: Cannot read properties of undefined (reading 'options')\nTypeError: Cannot read properties of undefined (reading 'options')\n    at Ye.allowVisualContainerPreload (https://content.powerapps.com/resource/powerbiwfe/scripts/reportEmbed.min.38732c582f72ce35a5d3.js:1:3500934)\n    at https://content.powerapps.com/resource/powerbiwfe/scripts/reportEmbed.min.38732c582f72ce35a5d3.js:1:3463706\n    at t.invoke (https://content.powerapps.com/resource/powerbiwfe/scripts/reportembed.externals.bundle.min.2d90cc3c3d2529b68936.js:5:14191)\n    at t.K.invoke (https://content.powerapps.com/resource/powerbiwfe/scripts/reportEmbed.min.38732c582f72ce35a5d3.js:1:803459)\n    at Object.onInvoke (https://content.powerapps.com/resource/powerbiwfe/scripts/reportEmbed.vendors.min.e0dd7bf7f46258cf6211.js:1:495105)\n    at t.invoke (https://content.powerapps.com/resource/powerbiwfe/scripts/reportembed.externals.bundle.min.2d90cc3c3d2529b68936.js:5:14131)\n    at e.run (https://content.powerapps.com/reso}"

 

When I try to load a single embedded report iframe on Chrome, it seems to not error out quite as often. However when I have multiple dashboards on the page loading at once, the error comes up more frequently. Please let me know if you have any suggestions. Thank you.

1 ACCEPTED SOLUTION
pbiuser1222
New Member

Update: I have seemed to fix the problem. For some reason, appending &embedImagePlaceholder=true to the report url comepletely fixes the issue. This seems to work regardless if you set up an image placeholder or not. I still get the previously mentioned error in the console but the reports seem to load fine on chrome now

View solution in original post

2 REPLIES 2
pbiuser1222
New Member

Update: I have seemed to fix the problem. For some reason, appending &embedImagePlaceholder=true to the report url comepletely fixes the issue. This seems to work regardless if you set up an image placeholder or not. I still get the previously mentioned error in the console but the reports seem to load fine on chrome now

Hello, would you be able to share how you came across this solution? Is that query param listed anywhere in the documentation? I haven't been able to find any references to it so far and I'm attempting to resolve this same issue using the powerbi-client-react component.

Helpful resources

Announcements
Europe Fabric Conference

Europe’s largest Microsoft Fabric Community Conference

Join the community in Stockholm for expert Microsoft Fabric learning including a very exciting keynote from Arun Ulag, Corporate Vice President, Azure Data.

July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

July Newsletter

Fabric Community Update - July 2024

Find out what's new and trending in the Fabric Community.