Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
tina26508015
Frequent Visitor

Deployment Pipeline Seems to break refresh

Hello community,

we have a power bi dataset that all of a suden stuck in refresh for 5 hours and it keeps happening. Prior to that it was refreshing fine 7 min-8 min, I am able to refresh in the desktop as well. We use deployment pipelines, in test the same dataset refreshes without issues. If I take that same pbix and publish directly to prod again refreshes in 7 min. So by process of elimination it feels something is happening with the dataset when it's deployed via pipeline. It's not the first time, we opened a ticket with Microsoft too and so far did not get an answer. One time it was stuck for 2-3 days and then resolved on its own. The second time we had to delete prod version and redeploy from dev. That worked for about 3 weeks and now the problem is back. Any suggestions what is the issue? Thank you!

2 REPLIES 2
v-rongtiep-msft
Community Support
Community Support

Hi @tina26508015 ,

Is there an error message? Please refer the following steps:

  • The dataset may be very large or complex, so it takes a long time to refresh. You can try to reduce the size or complexity of your dataset, or use incremental refresh to only refresh the data that has changed.
  • The dataset may have some dependencies or relationships with other datasets or data sources, so it waits for them to finish refreshing before it can refresh itself. You can try to check the dependencies or relationships of your dataset, and see if you can remove or modify them to avoid conflicts or delays.
  • The dataset may have some issues with the deployment pipeline, such as corrupted files, incorrect settings, or incompatible versions.

Troubleshoot refresh scenarios - Power BI | Microsoft Learn

 

If it does not help, please provide more details.

 

Best Regards
Community Support Team _ Rongtie

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

The dataset is about 340 MB, so not huge. It refreshes fine both in dev and in test. It won't refresh in prod and I cannot overwrite dev copy by publishing directly to prod. Power bi recognizes that i am publishing dataset with the same name, it successfully publishes (but there is a message, that we successfully published but unable to refresh). And then when I check it's still the old version. I tried to publish directly since deployment from test to prod fails, without any specific error

 

Helpful resources

Announcements
July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

July Newsletter

Fabric Community Update - July 2024

Find out what's new and trending in the Fabric Community.