Forum Discussion
Deployment Pipeline Error - Changes made to the source dataset are preventing the deployment.
- 4 years ago
Hi,
The dataset that caused the issue was an SQL Server (On-Prem) database table. We had made many changes (add, remove, modify fields) and successfully deployed multiple times. Not sure what it was that broke the Pipeline.
The model itself has several SQL server data tables, dataflows from within the workspace and dataflows from a separate workspace.
I think I have solved the issue (still testing). I used ALM toolkit to sync the two datasets and it has just let me deploy to test, I had to then use ALM toolkit again as I got the same error Test --> Dev
I have just kicked off the PowerAutomate process that refreshes everything, hopefully will work!
itchyeyeballssuggestion to look at the diff using the ALM Toolkit was immensely helpful. In our particular case we ran into this issue because we set a table in our DEV environment to "Mark as Date Table". We had to revert that change in DEV for the pipelines to work again. My guess is that there are a multitude of other reasons why this may happen