Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

The ultimate Microsoft Fabric, Power BI, Azure AI & SQL learning event! Join us in Las Vegas from March 26-28, 2024. Use code MSCUST for a $100 discount. Register Now

Reply
Bhoga
Frequent Visitor

Date format DD/MM/YYYY (Australia) in published Power BI Report Slicer and data updated section.

Hi All

I am developing reports for my client located here in Melbourne, Australia, AEST (Australian Eastern Standard Time).

The moment I publish my Power BI Report from Power BI Desktop to Power BI Service, the date is changing from DD/MM/YYYY to MM/DD/YYYY (defaulting to US Date format)!

I have researched and tried many links as below but in vain:

1. https://community.powerbi.com/t5/Desktop/How-to-change-date-to-a-different-locale-s-format/m-p/83127...

2. https://community.powerbi.com/t5/Service/Date-issue-dd-mm-yyyy-vs-mm-dd-yyyy/m-p/560290#M57418

3. https://community.powerbi.com/t5/Service/How-to-change-date-format-from-MM-DD-YYYY-to-DD-MM-YYYY-in-...

Some of these links date back to 2017 and I'm sure someone out there must have figured out on how to get the Date format to DD/MM/YYYY.

I need the Date format to be as per Australian Standards i.e. DD/MM/YYYY.

Attached are the screenshots that will show you what I'm after.

 

DDMMYYYY_01.jpgDDMMYYYY_02.jpg

 

Kindly, help.

Thanks for your time in advance.

1 ACCEPTED SOLUTION
Nimai123
Post Patron
Post Patron

Hello @Bhoga 

 

I have tried with the sample file, what you have to do is to first change the format of the date column if working well and good and if not then 

 

Go in your date settings and apply the below settings.

 

Settings

Capture.PNG

 

Updated file

 

Capture.PNG

 

Regards,

 

I would appreciate Kudos if my response was helpful. I would also appreciate it if you would Mark this As a Solution if it solved the problem. Thanks!

 

View solution in original post

3 REPLIES 3
Nimai123
Post Patron
Post Patron

Hello @Bhoga 

 

I have tried with the sample file, what you have to do is to first change the format of the date column if working well and good and if not then 

 

Go in your date settings and apply the below settings.

 

Settings

Capture.PNG

 

Updated file

 

Capture.PNG

 

Regards,

 

I would appreciate Kudos if my response was helpful. I would also appreciate it if you would Mark this As a Solution if it solved the problem. Thanks!

 

It works fine in powerbi desktop app but the moment it is published it changes date to MM-DD-YYYY format. I have double checked my settings and they are correct as per your screenshot. 

GilbertQ
Super User
Super User

Hi @Bhoga 

 

If you can please have a look at the following blog post to see if this is possible. As explained in the blog post it is due to the clients settings

 

https://www.fourmoo.com/2020/06/24/getting-the-correct-date-format-to-be-displayed-in-the-power-bi-s...





Did I answer your question? Mark my post as a solution!

Proud to be a Super User!







Power BI Blog

Helpful resources

Announcements
Fabric Community Conference

Microsoft Fabric Community Conference

Join us at our first-ever Microsoft Fabric Community Conference, March 26-28, 2024 in Las Vegas with 100+ sessions by community experts and Microsoft engineering.

February 2024 Update Carousel

Power BI Monthly Update - February 2024

Check out the February 2024 Power BI update to learn about new features.

Fabric Career Hub

Microsoft Fabric Career Hub

Explore career paths and learn resources in Fabric.

Fabric Partner Community

Microsoft Fabric Partner Community

Engage with the Fabric engineering team, hear of product updates, business opportunities, and resources in the Fabric Partner Community.

Top Solution Authors
Top Kudoed Authors