Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
trt18-sistemas
Advocate III
Advocate III

Dataset parameters disabled (greyed) at Pipeline

Hi there,

 

I'm facing a similar problem to the one reported here (https://community.powerbi.com/t5/Service/Deployment-pipelines-Parameters-Invalid-Rule/m-p/1175862).

I have Premium per User licence and I'm trying to use parameters at pipeline, but it's not working. I've created a very simple dataset that loads a manual created table and it has a parameter that is not actually used. 

 

Below is the code to create the table:

 

 

let
    Fonte = #table({"col1", "col2"}, {{"val1", 1}, {"val2", 2}, {"val3", 3}})
in
    Fonte

 

 

And now the parameter configuration window:

 

carlosmoura_0-1645182342309.png

 

When I upload this report to dev workspace it runs ok, but when I try to edit the Parameter at test workspace it's not enabled.

 

That's the pipeline screen showing that all datasets and reports and synchronized:

 

carlosmoura_1-1645182447370.png

 

But, when I try to set the parameter at Test workspace it's disabled:

 

carlosmoura_2-1645182518508.png

 

 

On the Message I refered above (https://community.powerbi.com/t5/Service/Deployment-pipelines-Parameters-Invalid-Rule/m-p/1175862), the solution is to set parameters and access at dataset on its workspace. I did it, but it's disabled anyway.

 

carlosmoura_3-1645182737734.png

 

 

Any clue?

 

1 ACCEPTED SOLUTION

Posting the solution.

 

On my example, the parameter data type is set as "any" (qualquer in portuguese). By setting as "text" it worked.

 

As simple as that .... rsssss

View solution in original post

11 REPLIES 11
Nimrod_Shalit
Power BI Team
Power BI Team

Please verify that you are the owner of the dataset in Test stage.

Onlt dataset owners can configure rules.

Actually, I didn't check it on the right place. My access right to the dataset at Test Workspace is as Administrator/Owner ("Proprietário" in Portuguese):

 

carlosmoura_1-1645354108457.png

 

 

additional option is that the dataset is only connected to Power Bi artifacts, such as dataflows, and not to external data sources. Can you specify which data sources are this dataset connected to?

 

Hi @Nimrod_Shalit,

 

At this simple example it's not connected to any datasource. I've created a table as mention on my first message.
On my real world case, where I'm facing the same problem, I'm connected only at dataflows. I'm using textual parameters to define the name of at which workspace connect to (it's not a connection parameter).

@trt18-sistemas,
When you are connecting only to a Power BI artifacts, such as dataflows, we will handle the connections across WSs for you. no need to setup rules. 

See more here- Deployment pipelines, the Power BI Application lifecycle management (ALM) tool, process - Power BI |...

Please remove the parameter from the connection, as it probably disrupts the auto-bind process to happen.

Hi @Nimrod_Shalit,

 

Reading the link you sent to me, it seems that it was suppose to work, as written at https://docs.microsoft.com/en-us/power-bi/create-reports/deployment-pipelines-process#auto-binding-a.... But, diving deeper into this subject I found this https://docs.microsoft.com/en-us/power-bi/create-reports/deployment-pipelines-get-started#deployment.... The 7th item says: "Rules for datasets that use dataflows as their source, are not supported.", which is excatly my case. My dataset has only one data source which is a Dataflow hosted in a different worspace.

Trying to solve my problem, I tried to implement a similar solution recommended here https://docs.microsoft.com/en-us/power-bi/create-reports/deployment-pipelines-process#avoid-using-au....

 

  1. I connected my dataset to my production Dataflow (hosted in a different workspace, that has no pipeline implemented), removind all parameters concerning to data source connections;
  2. Published my Dataset at Workspace [Dev];
  3. Connected my Paginated Report to the Dataset published at Workspace [Dev] and publised it at the same workspace;
  4. Using pipeline, deployed Dataset + Report + Paginated Report to Workspace [Test];
  5. Using pipeline, deployed Dataset + Report + Paginated Report to Workspace [Prod];
  6. Tried to access Paginated Report at Workspace [Prod] , but I encouter a error (picture 1 bellow);
  7. Downloaded Paginated Report from Workspace [Test] and checked its connection, then I found out that it's connected to the Dataset from Development Workspace (picture 2 bellow), which means that Autobind Pipeline didn't work.

 

carlosmoura_0-1646253495785.png

Picture 1) error trying to open Paginated Report at Workspace [Prod]

 

 

carlosmoura_1-1646253551757.png

Picture 2) Autobind on Paginated Report deployed at Workspace [Test] didn't work and kept the connection to the Dataset at Workspace [Dev].

 

Any suggestion on how to make pipeline works on this scenario?

  • Still not sure why are you trying to use a rule for the dataflow-->dataset connection. What's the use case where you need a rule and not the auto-binding?
  • As for the paginated report not being auto-binded to the dataset in Test, this sounds like a bug, and you should open a support ticket so we can further investigate.

@Nimrod_Shalit , I`m sorry for ommit that info. Dataflows are hosted at a specific workspace where I can not upgrade for Premium as pro users are accessing reports and dashboards hosted at that workspace. So, it would required more PPU licenses or I would have to separete Dataflows from Reports/Dashboards, but it will demand certain amount of time and effort. In that case I need to find a alternative solution.

 

I'll open a support ticket.

 

Thanks for your attention.

Posting the solution.

 

On my example, the parameter data type is set as "any" (qualquer in portuguese). By setting as "text" it worked.

 

As simple as that .... rsssss

Hi @Nimrod_Shalit,

 

I forgeted to mention that part. I'm the owner as I created the workspace. My profile has administrator access to the workspace, check it at image below.

 

carlosmoura_0-1645353128769.png

 

Helpful resources

Announcements
July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

July Newsletter

Fabric Community Update - July 2024

Find out what's new and trending in the Fabric Community.