Showing results for 
Search instead for 
Did you mean: 

Fabric is Generally Available. Browse Fabric Presentations. Work towards your Fabric certification with the Cloud Skills Challenge.

Frequent Visitor

Dataflow data source credentials issue

Hello everyone!


I'm having situation with Dataflow Data Source credentials in Power BI service. I can't edit them, I can't even access them. 
It looks like this:


This is the case for all dataflows that I have, except the ones that I have in Test Workspace (that's my test office 365 group). They are all under my command. My co-worker tried to do the takeover and after that I took them back, but apparently my credentials were remembered and I wasn't even asked to sign in again. 
I don't use gateways.
My data is coming from CRM (connecting trough CDM), SP online and i have couple entities that use OData. Everything is coming from cloud basically. 
Today I got an error which said my dataflows weren't refreshing because credentials were invalid. I saw it's beacuse I wasn't signed in and today I managed to edit my credentials for the first time in probably two weeks. I signed in again and after that I couldn't access credentials, again. 
Is this issue for the ticket or am I missing something?

Community Support
Community Support

Hi @skusulja ,

If you've fixed the issue on your own please kindly share your solution. If the above posts help, please kindly mark it as a solution to help others find it more quickly. Thanks!

Best Regards,
Yingjie Li


I was about to raise a ticket towards Microsoft but it started working on it's own. 

I haven't had the issues since. 
So I don't know what the problem was and what fixed it.

Community Support
Community Support

Hi @skusulja ,

Cannot reproduce it in my environment, I can edit the credentials of cloud data source normally. Please try to create a new dataflow with cloud data source to test whether you can set refresh and edit data source credentials.

If only the previous dataflow cannot edit credentials, I suggest to create a support ticket for further help.

Support Ticket.gif


Best Regards,
Yingjie Li

If this post helps then please consider Accept it as the solution to help the other members find it more quickly.


I created new dataflow (SP online list as data source) and I could access all dataflow data source credentials afterwards. 
Half an hour later, I couldn't anymore. A little bit later, I could again. Weird. 
I'll keep an eye one them and, if this continues, raise the ticket. 

Super User
Super User

this is ticket territory.  Did you play with the enhanced compute engine settings?

No, I did not .

Helpful resources

PBI November 2023 Update Carousel

Power BI Monthly Update - November 2023

Check out the November 2023 Power BI update to learn about new features.

Community News

Fabric Community News unified experience

Read the latest Fabric Community announcements, including updates on Power BI, Synapse, Data Factory and Data Activator.

Power BI Fabric Summit Carousel

The largest Power BI and Fabric virtual conference

130+ sessions, 130+ speakers, Product managers, MVPs, and experts. All about Power BI and Fabric. Attend online or watch the recordings.

Top Solution Authors
Top Kudoed Authors