Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Earn a 50% discount on the DP-600 certification exam by completing the Fabric 30 Days to Learn It challenge.

Reply
JD0963
Helper I
Helper I

Data colors changing once published to web?

Hi, I have some visuals on my report which use the correct color in PowerBI desktop, however when I publish to the web these colors revert back to the default teal color. Any reason why? I am using bar chart visuals..

 

I have tried the fix (where people suggest adding values to the axis and then re-selecting the default color) however this doesn't work.

 

I also have the word cloud custom visual which is resetting to the default multicolored appearance after publishing.

 

Does anyone know why this might be? I am using the latest version of PowerBI (November)

 

Thank you

 

1 ACCEPTED SOLUTION
jrw0712
New Member

I'm also getting this when I publish from the desktop to the web and can't find a way to get it to stop. I upgarded this past weekend to the November update.

 

For some reason, off track will change from red to teal when I publish it to the web. What looks like the legend is actually a different visualization then the gantt chart (slicer) with only the legend showing so that when I click on them, only the selected status' show in the gantt chart instead of them being greyed out if you were to use the gantt legend.

 

Power BI Desktop screenshot. Notice Off Track is red in slicer Legend and red in the gantt chart

Power BI Desktop screenshot.jpg

Power BI Workspace/Published to web view. Off Track changes to teal in the Legend. You'll notice that the gantt stays the same because as I mentioned they're acutally two different visualizations. 

Power BI Web workspace screenshot.jpg 

View solution in original post

8 REPLIES 8
OneWithQuestion
Post Prodigy
Post Prodigy

How is this STILL a problem... it STILL happens with column charts too...

Why does this clear error in software still exist over 5 years later?

sebbayard
Helper I
Helper I

Hi all, 

have the same problem here, the report is actually reverting back to the custom theme after you make changes to the report. 

It looks fine in PBI service, but the public URL is formatted with the default PBI theme 😞

 

A workaround sofar that is actually working is to upload the report and use it as template, and then make a copy of it and publish to web. Sofar the copy of the original works perfectly fine after making updates/ changes in the report.

To edit a report in PBI service is not always optimal though - you might need to insert an image and that can only be done in desktope for instance. 

 

However, hope this can help.

I really hope this issue will be adressed soon and resolved. 

 

Thanks

Ben

Pardon moi, could you be more detailed about the procedure? 😅 
How/where could I "make a copy"? 
This issue is very frustrating... 😥

Ah of course.  Edit the report and save as a new one in PBI service. 
Then publish to web 😊

 

jrw0712
New Member

I'm also getting this when I publish from the desktop to the web and can't find a way to get it to stop. I upgarded this past weekend to the November update.

 

For some reason, off track will change from red to teal when I publish it to the web. What looks like the legend is actually a different visualization then the gantt chart (slicer) with only the legend showing so that when I click on them, only the selected status' show in the gantt chart instead of them being greyed out if you were to use the gantt legend.

 

Power BI Desktop screenshot. Notice Off Track is red in slicer Legend and red in the gantt chart

Power BI Desktop screenshot.jpg

Power BI Workspace/Published to web view. Off Track changes to teal in the Legend. You'll notice that the gantt stays the same because as I mentioned they're acutally two different visualizations. 

Power BI Web workspace screenshot.jpg 

Hi guys,

I do not see a solution to this problem, have you found any?

 

Best regards,

Dimitar 

natabird3
Continued Contributor
Continued Contributor

Also, getting this issue in Pie Charts, is there a fix for this yet?

Helpful resources

Announcements
LearnSurvey

Fabric certifications survey

Certification feedback opportunity for the community.

Top Solution Authors