Forum Discussion
DM_GWPipeline_Gateway_MashupDataAccessError On-Premises Data Gateway Error
Hi Anonymous ,
Whether your problem has been resolved? Is there anything else that needs assistance regarding this thread?
Best Regards
Rena
This is to let everyone know that our issue stopped being an issue on September 1, 2020 when refreshes started working again without errors (almost a month after they first failed). However, if it helps anyone to troubleshoot in the future, we identified another workaround along the way.
- Our sources were SharePoint on-prem lists that were appended as part of the M query in Power BI.
- They were all in sub-sites of one parent site and there was one gateway connection to the parent site.
- After the report failed to refresh with Append, we tested that lists could still be refreshed individually (without appending) using the above gateway connection.
- The workaround, though, was to create a gateway connection per each sub-site/source (using the same account and password, so no change in SharePoint, only several new gateway connections created instead of one).
- Then each list was mapped to its own gateway connection and with that, the refresh of the report with appended lists worked - that was a more acceptable temp solution for us as it didn't require any changes inside the report.
- Anonymous6 years agoNot applicable
Hi OB ,
It's glad to hear that the refresh start working. Thanks for your reply and sharing your solution. There are some threads about this type of problem which schedule refresh can't work properly due to the append query. There is no good solution yet. Your solution may help people who have similar problem. Could you please just mark your last post as Answered? It will help the others find your solution easily and fast. Thank you.
Best Regards
Rena
- OB6 years ago
Helper II
Anonymous , please send me a snapshot how to mark the post as Answered 😂 The very first post in the thread wasn't mine, though. In addition, there were two workarounds, one Union in DAX and one gateway connections, so both should be marked as solutions, even though I would still call them workarounds.
Thank you!
- Anonymous6 years agoNot applicable
Hi OB ,
Please check if there are two buttons ("Reply" and "Accept as Solution" button) which are same with the ones in below screenshot under each reply in your thread? You can click the "Accept as Solution" button to mark your two workarounds as solutions.
Best Regards
Rena
- Anonymous6 years agoNot applicable
How did you manage to create a a sub source for eacn connection without going through the root URL? Im trying to follow this temp solution, but can only create a SharePoint source using the root URL. Am I missinf something here?
- OB6 years ago
Helper II
Anonymous
To clarify, I am going through the root connection. What I meant by sub-sites is, for example
The Desktop file has a separate connection to each site, then the two sources are appended by applying steps in Transform Data and the refresh works, but it didn't work in PBI Service using one gateway connection to the http://abc/sites/def/
So we created two gateway connections in PBI Service, one for http://abc/sites/def/AAA and one for http://abc/sites/def/BBB
Then we mapped each source to its own connection and the refresh worked in PBI Service.
This is how gateway connections would look like for the above sources:
Data Source Name
AAA
Data Source Type
SharePoint
Data Source URL
Authentication
WindowsData Source Name
BBB
Data Source Type
SharePoint
Data Source URL
Authentication
Windows- Anonymous3 years agoNot applicable
Hi OB ,
Hope you are doing well.
I am facing the same issues while refereshing my data in PBI Servie . Below is the screenshot for the same.
If you have the solution Could you be please help what needs to be done?
Thanks,
Ashish