Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
tyswizzle
Advocate I
Advocate I

Custom Data Label missing from Power BI Service but present on Desktop

Update Jan 2024 -- I believe the issues are getting worse 

Hi! 

I've only found one post that relates to this topic, but the solution doesn't seem to work for me. https://community.fabric.microsoft.com/t5/Issues/Custom-Label-for-Data-Label-not-working-on-PowerBI-...

Similar to the referenced post, I created a custom data label to control when/where labels are shown.  The screenshots below depcit the same page on Service and Desktop but the custom labels are only present on desktop. DesktopDesktopServiceService

 

The visual settings for the data label:Settings.png

 

And the measure itself: 

DataLabel.Safety.TPIR =
    var _TPIR = [Safety.TPIR.OverTime]
    var _month = MAX(slicer_Dates[Month])
    var _mod = 3
    var _currMonthMod =
        MOD(
            MONTH(
                MAX(slicer_ProjectInfo[date.Safety.Latest])
            ),
            _mod
        )
    var _formattedTPIR =
        IF(
            _TPIR > [Graph.Max.Safety.TPIR],
            ">"& FORMAT([Graph.Max.Safety.TPIR], "#,##0.00"),
            FORMAT(_TPIR, "#,##0.00")
        )
return
    IF(
        ISBLANK(_TPIR) || MOD(_month, _mod) <> _currMonthMod,
        BLANK(),
        _formattedTPIR
    )
 
I need custom labels so I can constrain the bounds without losing information while maintaining Visual clarity through a limited number of labels. 

Any ideas why the custom label doesn't appear in Service?
 
Thanks for any and all help!
47 REPLIES 47
Raveendraa
Regular Visitor

Hello, Everyone

 

Still I am facing same issue, Custom labels are not present in Power BI Service. kindly suggest here.

Jitendrav
Frequent Visitor

Dear All , { As par New Update Dec 2023}

This Came after new Update Which has two points for Reprantation as in Data Lable 
1 Value 
2 Detail (New) 
Due To this new update There might not have same Masure so it will not Display Value So Pleases Use same masure There Also ...

Thanks a lot @Jitendrav 

This helped solve the issue!

Nazira
Regular Visitor

It is working on the Desktop but the issue is happening on the service side.Can you give us an update once it gets resolved.Thank you!

 

Just Define Same thing In Detail Also As New info added only ....at Same Place Where you Drag values.

Hmm. This was fixed some time ago so not sure why it's still not working for you as I just checked and it's working for me still.

I think this happens is certain situations. One situation that it does happen in is when the Apply settings to 'All' Data Series Value well is populated (whether it is turned on or off) with something other than the custom label that matches what is selected in the individual series with the custom label, it will cause the custom label on the desired series to not render properly but instead render what is selected in the 'All' series. To verify, can you please check to see if your data series with the custom label matches the Value selected of the Apply settings to the 'All' series?

 

This is also the fix (have the two show the same custom label value. However, this is a pain if you have many reports that need this manual fix, so hoping that MS can push through a fix so we do not have to manually update all impacted reports.

arca123
Advocate I
Advocate I

Hi!
I agree with user Jitendrav that the issue is back.

Jitendrav
Frequent Visitor

This is Again Come Back Please Provide Permanat Solution if any one have .....

Kaii
Helper I
Helper I

is still not been fixed yet?

the fix is scheduled for 10/27

bjorn99_
Frequent Visitor

I'm also experiencing the same problem with custom data labels not showing up in the Power BI Service. When they previously did, noticed it while I was presenting one of my reports last week.

Power BI Desktop:

bjorn99__0-1696838868308.png


Power BI Service:

bjorn99__1-1696838896056.png

 




v-tangjie-msft
Community Support
Community Support

Hi @tyswizzle ,

 

This issue has been confirmed as a known issue internally. Please be patient to wait for fixing. If there is any news, I will update it here.

---------Update:

The issue has been fixed.

 

Best Regards,

Neeko Tang

 

Please Update This Is Came back Again Today ..........

MyriamW
Frequent Visitor

Same here

Afives522
Frequent Visitor

Hi,

 

Just want to confirm since I just recently used the custom label feature. This feature was working correctly before, and then just suddenly disappeared lately? I asked since I'll communicate it to our stakeholders. Thanks. 

Also my experience. I assumed it was because I changed the measure, but I don't think that's the case anymore.

Just got off a call with support (#2310040010003433). She will check internally to see if it is currently being worked on and I also referenced her to this post (thank you for posting!). She captured some screenshots and did some tracing during our session and will communicate when she finds more (she said possibly Monday).

Are there any updates??

 

I have a deadline for my report in 2 weeks and would really need to get this fixed soon 😊

I received a response this morning that the fix is scheduled for 10/27.

Helpful resources

Announcements
Europe Fabric Conference

Europe’s largest Microsoft Fabric Community Conference

Join the community in Stockholm for expert Microsoft Fabric learning including a very exciting keynote from Arun Ulag, Corporate Vice President, Azure Data.

Power BI Carousel June 2024

Power BI Monthly Update - June 2024

Check out the June 2024 Power BI update to learn about new features.

RTI Forums Carousel3

New forum boards available in Real-Time Intelligence.

Ask questions in Eventhouse and KQL, Eventstream, and Reflex.

Top Solution Authors