Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
tyswizzle
Advocate I
Advocate I

Custom Data Label missing from Power BI Service but present on Desktop

Update Jan 2024 -- I believe the issues are getting worse 

Hi! 

I've only found one post that relates to this topic, but the solution doesn't seem to work for me. https://community.fabric.microsoft.com/t5/Issues/Custom-Label-for-Data-Label-not-working-on-PowerBI-...

Similar to the referenced post, I created a custom data label to control when/where labels are shown.  The screenshots below depcit the same page on Service and Desktop but the custom labels are only present on desktop. DesktopDesktopServiceService

 

The visual settings for the data label:Settings.png

 

And the measure itself: 

DataLabel.Safety.TPIR =
    var _TPIR = [Safety.TPIR.OverTime]
    var _month = MAX(slicer_Dates[Month])
    var _mod = 3
    var _currMonthMod =
        MOD(
            MONTH(
                MAX(slicer_ProjectInfo[date.Safety.Latest])
            ),
            _mod
        )
    var _formattedTPIR =
        IF(
            _TPIR > [Graph.Max.Safety.TPIR],
            ">"& FORMAT([Graph.Max.Safety.TPIR], "#,##0.00"),
            FORMAT(_TPIR, "#,##0.00")
        )
return
    IF(
        ISBLANK(_TPIR) || MOD(_month, _mod) <> _currMonthMod,
        BLANK(),
        _formattedTPIR
    )
 
I need custom labels so I can constrain the bounds without losing information while maintaining Visual clarity through a limited number of labels. 

Any ideas why the custom label doesn't appear in Service?
 
Thanks for any and all help!
48 REPLIES 48

I received a response this morning that the fix is scheduled for 10/27.

I now received a response as well, seems the fix will be rolled out at slightly different times in different regions, in North Europe its scheduled by "mid-next week".

I just checked and the issue is fixed in North America. 

The issue seems to have appeared again. Anyone facing the same issue?

I am facing the same issue in the Power BI service. The data labels are showing up but do not reflect the custom data label value associated. It is correct in  Power BI desktop. Anyone experiencing this issue? I am in North America.

I am not seeing it currently. I am in North America.

Looking this morning, I do see the issue now ☹️

Just now looked at desktop and it is not showing on their either!

I found a temporary work around. Use the new Detail feature with the Dec 2023 update for your Custom Label and turn off the Value display. The downside to this is that the text formatting is very limited (I.e., cannot bold, etc.). It is a temporary solution for me until this get fixed.

really? I dont have this issue at PowerBI desktop (Version: 2.119.986.0 )

You may once you get the lates version: 

 

Version: 2.124.1052.0 64-bit (December 2023)

Not sure which to mark as a solution, but the problem is fixed! Thanks everyone!

"America first" 🙂

Good to know the ball is rolling

Nice!

We have been in contact with support as well, uploaded pbix to them Oct 6, and yesterday got this

"We would like to let you know that we have already analyzed the pbix and have contacted our product group team for the same. Once we receive an update, we will let you know."

Will try to find out more

 

Its also listed here: https://support.fabric.microsoft.com/en/known-issues

Thanks for the update! Someone from the Community also responded to this post, so hopefully this gets fixed soon!

Yes, that is my experience.

sd_kevin
Advocate II
Advocate II

I checked and have the same issue with my published reports that use to render the customer labels just fine. I just opened a support case seeing there have not been any responses from MS on this forum.  It says Expect reponse within: "2" - not sure if that means 2 hours or 2 days?

Awesome, thank you! Please keep us updated if/when they repond! 

SaiManjunathRB
Frequent Visitor

@community

can you please have a look at this

 

YamXQ
New Member

I believe this is a bug. Can someone raise this up to Microsoft developers?

Helpful resources

Announcements
July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

July Newsletter

Fabric Community Update - July 2024

Find out what's new and trending in the Fabric Community.