Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Earn a 50% discount on the DP-600 certification exam by completing the Fabric 30 Days to Learn It challenge.

Advocate I
Advocate I

Credential Missing

I got the below error while refreshing the dataset through on-premise data gateway


Last refresh failed: Wed Aug 12 2020 16:24:28 GMT+0800 (Hong Kong Standard Time)
Invalid connection credentials.Hide details

Underlying error code:-2147467259
Underlying error message:Credentials are required to connect to the File source. (Source at \\apps01\flexpmsexport\debitnote.xlsx.)
Activity ID:436c3ad2-9b29-4cef-add0-c811ca6aa2c1
Request ID:a61b56cf-7ac1-8735-74e3-a6e64c73d6cb
Time:2020-08-12 08:24:28Z


But when i try to view the gateway connection in dataset setting, i got a green tick for all datasource files, which means the credential i provided in the gateway is correct and tested successful.


I've already tried to delete the whole report and dataset and then re-publish it from PowerBI Desktop (data refresh in PBI Desktop is okay), but also got the same error message.


Please help........



Helper II
Helper II

I've been having this same issue (see my post above).  However I noticed on the August 2020 On-Premises Data Gateway notes state that the Mashup Engine has been updated and now matches the August 2020 version of Power BI Desktop.  I went ahead and updated the Gateway to the new August 2020 version.  I then tested a couple of reports that have been failing and now they are sucessfully working. 


You can view the MS Blog post about the gateway update at


Hopefully this resolves anyone who is having this issue.

Super User
Super User

Hi @sunnyleung ,


Please check the below thread and see if its solution helps:


Check in the issue listed:


Also, if all the credentials and appropriate and still invalid credential error occurs, you can probably create a support ticket here.


Give a thumbs up if this post helped you in any way and mark this post as solution if it solved your query !!!

Hi @Anand24 ,


That didn't work, the server name and credentials are all good and correct. I think that's a bug on the latest pbi service update.






Helper II
Helper II

We've had the same or at least very similar issue since the beginning of last week: error when refrehing in PBI Service, but no issues in PBI Desktop.


This affected two reports, one that uses SharePoint Lists on prem, the other one that uses files stored in SharePoint on prem (Gateway set as Web).  Both reports use Append in Power Query.  The latter report could be fixed by recreating the Append table again from scratch in a new report.  The former (SharePoint lists) refreshes fine if the sources are NOT appended, but fails to refresh when an Append table is created in Power Query (no issues when using Union in DAX). 


The error includes reference to DM_GWPipeline_Gateway_InvalidConnectionCredentials although the gateway connection gives no errors.

It also includes reference to Microsoft.Data.Mashup.CredentialError.DataSourceKind", so that's why we went to test and found out that the Append table is the reason of failing refresh.

We had June 2020 gateway when the issue happened in the beginning of August 2020, then upgraded the gateway to the latest availalbe at that time = July 2020, then later in the month to August 2020 and the issue remained. 


We found another temporary workaround - check it here:


But I should say that the original report that failed to refresh with appended tables has been successfully refreshing since September 1, 2020 again without any changes on our side.

Helper II
Helper II

I started getting this same error message starting this last Friday.  My report is also showing the green checks under the dataset and the gateway shows connection successful.  


Here is the kicker in my case.  I have two reports that both use the same file (same file location and everything) and both using the same data source on the enterprise gateway.  One report sucessfully updates while the other errors out with the CredentialMissing error.  I would think both would error out if the credentials weren't correct or missing.  


CredentialMissing ErrorCredentialMissing Error


Helpful resources

RTI Forums Carousel3

New forum boards available in Real-Time Intelligence.

Ask questions in Eventhouse and KQL, Eventstream, and Reflex.


Fabric Monthly Update - May 2024

Check out the May 2024 Fabric update to learn about new features.


Fabric certifications survey

Certification feedback opportunity for the community.

Top Solution Authors