Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
cfleischhacker
New Member

Couldn’t retrieve the data for this visual

Couldn't load the data for this visual Couldn’t retrieve the data for this visual. Please try again later. Activity Id126bd6eb-cdf7-43e3-95f4-53c128dde41f TimeTue Jul 28 2015 13:33:24 GMT-0600 (Mountain Daylight Time) Version11.0.9167.449 Cluster URIhttps://wabi-west-us-redirect.analysis.windows.net

16 REPLIES 16
alexgs
Frequent Visitor

The same happened to me.
I found the error, was an invalid value, the date was calculated with formula, uniting day month year, but in some occasions the day had value 0, and this value caused error in the formula.

To resolve i use a "IF" to remove that value 0.
But before publishing bi power, my report online that did not do any modification and it worked!
I have seen that power BI is very unstable, mistakes appear and disappear out of nowhere. Smiley Frustrated

I have a similar problem, assistance would be appriciated

 

I have a report that has been able to be shared across team members, having updated the layout and presentation it now has a problem, all the people it is shared to do not see the dashboard visualisations (no error, power bi logo). Clicking the dashboard takes them through to the report, the report is unable to load

 

I have reduced the report back to the basic report to eliminate issue with no joy.

 

I can load the published document without any problem but the people it is shared to receive the error message below

 

Couldn't load the data for this visual

Couldn't retrieve the data for this visual. Please try again later.


Please try again later or contact support. If you contact support, please provide these details.

 

Also if after publishing I try to “get quick insights” I receive the message below

 

 

Something went wrong

Sorry, we couldn't finish searching for insights in your data right now. Please try again later

 

I believe these two errors must be connected.

 

All other reports I run have never had this issue

 

For what it's worth the data is being pulled from google Analytics

 

Kind Regards

 

David

Hi David,

I have a similar problem sharing a dashboard / content pack.

 

I think I've pinpointed it down to my dataset having multiple connections - one being SalesForce and one being Excel. The refresh occurs fine in my session I published it on, but as soon as I share it other users get the same 'couldn't load the data for this visual'.

 

A couple things I'd ask:

1. Do you have multiple data sources within your dataset or just Google Analytics?

2. If from the team member you shared it with you had them COPY the dashboard - does the copied version display ok? This is the experience we're having.

 

Look forward to your response.

 

Cheers,

Cody

Hi Cody

 

Correct on both counts the problem sounds identical

 

1. Yes I have multiple connections, Google Analytics, PostgreSQL, Excel and CSV

2 Yes I have sent the dashboard to a team member and he has published it, shared it with me. He can view without a problem, I get 'couldn't load the data for the visual'. Consistant behaviour.

 

The error suggests 401 unauthorised access.

 

I have used chrome developer tools to view the http content, sent the HAR  (http archive file) file to Microsoft.

 

As soon as I hear anything I will post the answer

 

Cheers

 

David

 

Hi David,

In my case, this turned out to be an oversight on my part...

 

I had gone poking around in the new Role Level Security in my Power BI Desktop file before publishing and created an empty 'New Role' which noone had access to.

 

Both add the users to the role in the dataset in the Power BI Service and removing / re-publishing the file has allowed sharing without issue.

 

May be you'll have the same simple fix - obviously a more descriptive error would have pointed me in the right direction!

 

Cheers,

Cody

Hi Cody,

 

Without looking I can only believe it is the same issue, I also have been interested in the new Role Level Security, the error suggests it authorisation issue.

 

Thank you for the direction, I will confirm the outcome.

 

Kind regards

 

David

Hi All,

 

This has been resolved, the issue was with "Role Level Security". 

 

I created a role that restricted the report to only one county. I only had one individual in this role, but the report was not shared with him. Not sure this should have been an issue, but once the role was deleted the reports displayed correctly.

 

As the owner obtaining Quick insights was also affected by this, once the role was removed everything was happy.

 

Tread carefully with "Role Level Security"

 

Thanks Cody for pointing me in the correct direction.Smiley Happy

 

Cheers

 

David

Hi David,

 

Good to hear, obviously we're not alone working our way through the Role Level Security.

 

I suggested to Microsoft they enhance the related error message and it's been passed up to the product team.

 

Cheers,

Cody

Hi,

 

It appears that Role level Security, without being used it defaults to everyone you have shared with having access to everything.

 

Once you introduce a Role that default disappears and you will need an explicite role to enable you dashboard to others

 

Cheers

 

David

freitasm
New Member

Any luck with this? I have a report published to web that loads fine. If you the check a box in a selector list it sometimes shows data, sometimes shows the "Couldn't load the data for this visual" message.

 

Here is the thing: sometimes if I select a different checkbox and go back to my previous selection it works. Sometimes if I refresh the page it works, sometimes it fails for every checkbox I try.

 

Is there any word on what causes this?

 

drluong
New Member

I think maybe related to windowns. At the present, I used to at once 2 win 10 and 7 and saw win 10 could load, win 7 could'd load.

kcantor
Community Champion
Community Champion

I closed the browser and mine came back online. It happened twice today but both times closing the browser seemed to work. They are still active.

 





Did I answer your question? Mark my post as a solution!

Proud to be a Super User!




marambio_erika
New Member

Was there any resolution to why this is happening? I have the same error and I haven't been able to get any idea on how to fix it. I have a help ticket in with Microsoft, but they are taking forever to get back. Any insight would be great to get this fixed. Thanks!

I was never able to resolve this unfortunately.  One thing you could try is making sure your data sources are in the same Azure region as power BI.

cdotzenrod
Advocate I
Advocate I

I'm getting a similar error for my streaming Power BI dashboard.  My dashboard was working fine until this morning.  I have a hunch there is some sort of maintenace going on but have not heard any chatter on if that is true. By chance, does your dashboard get data from Azure? 

I'm also getting the same error on a new dataset from Azure SQL database.

Helpful resources

Announcements
July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

July Newsletter

Fabric Community Update - July 2024

Find out what's new and trending in the Fabric Community.