Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Register now to learn Fabric in free live sessions led by the best Microsoft experts. From Apr 16 to May 9, in English and Spanish.

Reply
Vladisam
Helper II
Helper II

Couldn't Publish to Power BI. An error occurred while contacting the service

Hi,

 

I am encountering following error message intermittently for couple of weeks now:

Couldn't publish to Power BI
An error occurred while contactingt the service (the remote service point could not be contacted at the transport level). Please contact your IT administrator if this issue persists.

I was on December 2022 version when it started, now on February 2023 and it still persists.

Any help or ideas are welcome.

Vlad.

 

4 REPLIES 4
jaweher899
Super User
Super User

The error message you are encountering while publishing to Power BI indicates that there is a problem with the connection between your computer and the Power BI service. This could be caused by a number of issues, including network connectivity problems, server issues, or issues with your local software configuration.

Here are a few things you can try to resolve the issue:

  1. Check your network connectivity: Make sure that your computer is connected to the internet and that you have a stable connection. You may also want to try restarting your router or modem to ensure that your connection is functioning properly.

  2. Check the Power BI service status: Check the Power BI service status page to see if there are any reported outages or issues that may be causing the problem.

  3. Clear your browser cache: Clearing your browser cache can help resolve issues with website connectivity. Try clearing your browser cache and then attempting to publish again.

  4. Try publishing from a different location: If possible, try publishing from a different computer or network to see if the issue is specific to your local environment.

  5. Contact Power BI support: If the issue persists, you may want to contact Power BI support for further assistance. They may be able to provide additional troubleshooting steps or identify any known issues that may be causing the problem.

Thanks for your suggestions.

I have extra "twist" - and I am trying to understand if it affects this issue. I work mostly at home, recently changed internet provider and unfortunately service was degraded (instead of improvement 😞 ). Also, during recent visit to the office had wi-fi connectivity issues. I received laptop couple of month ago, and had to run updates as advised by our tech support. It solved wifi issue, but i still encountered failure when publishing to service. It is much better now (more successful attempts to publish), and i am monitoring if publishing failures still persist.
I am trying to pinpoint which one of the issues really causes publishing failures.

Stay tuned.

Hi Vlad, did you end up finding any other solutions for this? My team is also experiencing the same issue with the exact same error message when trying to publish a large pbix file.

I think my issue is with internet provider. My files are not that big, though. I work with Premium capacities and switched to automated refreshes, so issue randomly happens, but I publish my updates rarely now. When update fails, i switch to my cell (5G) and it works.

Helpful resources

Announcements
Microsoft Fabric Learn Together

Microsoft Fabric Learn Together

Covering the world! 9:00-10:30 AM Sydney, 4:00-5:30 PM CET (Paris/Berlin), 7:00-8:30 PM Mexico City

PBI_APRIL_CAROUSEL1

Power BI Monthly Update - April 2024

Check out the April 2024 Power BI update to learn about new features.

April Fabric Community Update

Fabric Community Update - April 2024

Find out what's new and trending in the Fabric Community.

Top Solution Authors
Top Kudoed Authors