Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Reply
MAG_PRG
Regular Visitor

Copy a Visual as an Image - wrong style formatting applied

When using the "copy visual as an image" function in the app(not dashboard) the colors in the generated image are not the same as in the report. I tested this for multiple visuals in multiple reports, always the same issue. If we export the report as pdf the colors are all correct

In the report in the app:

MAG_PRG_5-1681217757432.png

 

Exported image:

MAG_PRG_4-1681217644961.png

 

Is there any way to fix this? It's a pretty useless feature for us if we can't have our standard formatting applied

1 ACCEPTED SOLUTION
v-yueyunzh-msft
Community Support
Community Support

Hi, @MAG_PRG 

According to your description, when you use copy visual as an image on Power BI Service, you get a visual that has a different color than the actual value.

Did your problem occur in recent weeks, I searched internally and found several similar ICMs that have not been resolved in recent .

According to the description of the product group, efforts are already underway to troubleshoot the issue and hope to resolve the issue in a short period of time, which will be fixed in the next version update.

Unfortunately, there may be some problems with this feature at this time, you can use manual screenshots as a workaround.

 

Thank you for your time and sharing, and thank you for your support and understanding of PowerBI! 

 

Best Regards,

Aniya Zhang

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly

 

 

View solution in original post

4 REPLIES 4
kbuckvol
Advocate I
Advocate I

Did you ever get this figured out?  It's weird because some of my visuals retain formatting but some of them don't.

I tested it now and the colors look correct, so it seems that issue was fixed for my visuals.

MAG_PRG
Regular Visitor

Hi

Thanks for the reply. A user reported to me that this had worked for her last month, but I don't think it has been used often, so hard to say exactly when it stopped working. We will user the workaround for now then, and hope it will be fixed in the next update

v-yueyunzh-msft
Community Support
Community Support

Hi, @MAG_PRG 

According to your description, when you use copy visual as an image on Power BI Service, you get a visual that has a different color than the actual value.

Did your problem occur in recent weeks, I searched internally and found several similar ICMs that have not been resolved in recent .

According to the description of the product group, efforts are already underway to troubleshoot the issue and hope to resolve the issue in a short period of time, which will be fixed in the next version update.

Unfortunately, there may be some problems with this feature at this time, you can use manual screenshots as a workaround.

 

Thank you for your time and sharing, and thank you for your support and understanding of PowerBI! 

 

Best Regards,

Aniya Zhang

If this post helps, then please consider Accept it as the solution to help the other members find it more quickly

 

 

Helpful resources

Announcements
July 2024 Power BI Update

Power BI Monthly Update - July 2024

Check out the July 2024 Power BI update to learn about new features.

PBI_Carousel_NL_June

Fabric Community Update - June 2024

Get the latest Fabric updates from Build 2024, key Skills Challenge voucher deadlines, top blogs, forum posts, and product ideas.