Forum Discussion
Configure Power BI Data Gateway to Data Lake Gen 2
- 5 years ago
With some help from colleagues we made this work today.
1) So the first thing was the data lake firewall settings.
I had set the private vnet data lake firewall to allow access from selected networks.
My vnet firewall allows host to host connection so Azure Storage explorer on my Gateway VM connects to the Data Lake fine. But that is not enough. On the data lake firewall make sure you have added the subnet ( your private vnet) and not left this blank. Should look something like this.2) My gateway installed with a local servce account. For now I left this alone, but believe a service account and spn registration are the way forward to support delegation.
3) Adding a data source in the Power BI Manage Gateways, brings up the screen in your post.
Server is the dfs URL for the container: https://<storage_account>.dfs.core.windows.net
Full Path is the resource part of the URI
https://<storage_account>.dfs.core.windows.net/<path>My container name is /test and leaving it at that brings back a list of files at the get data stage.
For Authentication I used the key option and copied the access key from the azure portal: Storage Account-> Access Keys (Not SAS Tokens)At this point my first sucessful save worked.
Click on your cluster name and it expands to list your data sources and "test all" should report sucess above each form.
4) In Power BI and your workspace add New and choose Data Flow.
Choose Add New Entries
Scroll or search data sources and select data lake gen 2
This form appears and it does not work too well.
The url is the https://<>..dfs.core.windows.net/<container> // Copy from Azure Storage explorer
The drop down lists your gateway.
And the authentication throws lots of strange errors, and despite that works if you click on Next.
I think this is all still in preview so good luck with support.
Regards
Keith
Did you get this to work?
I am trying to do the same: connect to a datalake on a vnet using a data gateway.
I have 400 errors (unable to connect to the data source), and it is not clear what information the configuration form requires:
Data Source Name : Assume this is just a label so any name will do (a-z)
Data Source Type: This is a drop down list and I select Data Lake Gen2
Server: What is this? I have tried the storage URL https://.... with and without the container ending.
Full path: Assume this is the URL including container https:......../test
Authentication Method: I am using Oauth and it does time out and I have to log in again.
Shame there is no documentation for this screen.
Regards
Keith
- tracyng09055 years ago
Helper I
no solution so far.... cant find any document about this as well....hope anyone can help here. Or should I raise a support call/ticket?