Skip to main content
Showing results for 
Search instead for 
Did you mean: 

Find everything you need to get certified on Fabric—skills challenges, live sessions, exam prep, role guidance, and more. Get started

Regular Visitor

Can't connect to tenant assigned Azure Data Lake Gen 2 storage account

My Power BI admin has connected a tenant assigned Azure Data Lake Gen 2 storage account in Admin Portal > Azure Connections. We followed the steps as per the documentation  

The storage account is
  • in the same location then my PBI tenant (in my case North Europe)
  • HNS is enabled
  • Power BI admin has Owner role assigned in the storage account

I created a new PPU workspace with Dataflow storage (preview) enabled. 




Then as a workspace admin I opened the Workspace Settings > Azure Connections where the checkbox for Use the default Azure connection was not checked, I selected/checked it, and there is no apply button on it. I navigate out of Workspace Settings and then navigate back to Workspace Settings of the same workspace to find the check box is again not selected.  



When I check the storage account, the powerbi and powerbi-backup folders are created there. Then I created and refreshed a dataflow in the same workspace, but the data is not populated in tenant-assigned ADLS Gen 2 storage account.

Has anybody faced the same issue? Is it a bug? Kindly help with the same! 

Community Support
Community Support

Hi @tabina 


Check the following aspects

  • Permissions Check: Ensure that the Power BI service principal has the necessary permissions on the storage account. This is crucial for writing data to the ADLS Gen2 account.

  • Dataflow Configuration: Verify the dataflow settings within the workspace to ensure they are correctly pointing to use the tenant-assigned ADLS Gen2 storage. Sometimes, manual adjustments might be needed to ensure the dataflow is correctly configured to use the external storage.





Best Regards,



If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Super User
Super User

Hi @tabina 


If you had previously connected a workspace and then remove the connection, this will be causing the error you are experiencing. What I would suggest doing is to remove the folder from the storage account and then try and recreate the connection

Did I answer your question? Mark my post as a solution!

Proud to be a Super User!

Power BI Blog

Hi @GilbertQ 

Thank you for your response. We tried that but we were unable to disconnect the current tenant assigned storage account from admin portal.

Raised a ticket with Microsoft Support but we closed the ticket as we were still not able to connect only to the tenant assigned storage account without enabling Workspace level storage setting that we didn't want to enable in our organization.

Helpful resources

Europe Fabric Conference

Europe’s largest Microsoft Fabric Community Conference

Join the community in Stockholm for expert Microsoft Fabric learning including a very exciting keynote from Arun Ulag, Corporate Vice President, Azure Data.

Power BI Carousel June 2024

Power BI Monthly Update - June 2024

Check out the June 2024 Power BI update to learn about new features.

RTI Forums Carousel3

New forum boards available in Real-Time Intelligence.

Ask questions in Eventhouse and KQL, Eventstream, and Reflex.

Top Solution Authors